
Font Facto GS
"...clearly the Cadillac of the field."

— in Cider/8+

Font Factory GS™ is a "font editor" that lets you change existing fonts or create
your own. Use it to enhance the screen display and print quality of just about
any Iias word processing, desktop publishing or drawing program. It's compatible
with IIGs programs like AppleWorks GS, BeagleWrite GS, GraphicWriter II I ,
HyperStudio, Medley, and Platinum Paint. I t 's also compatible with TimeOut
SuperFonts that runs on other Apple II models.

Font Factory GS is great for very large fonts, very small fonts and everything in
between. I t 's easy to create custom keyboard characters, symbols for math,
science, foreign languages and even picture fonts. Font Factory GS is especially
useful for automatically changing a font to a larger or smaller size.

"Font Factory GS is our favorite font editor."
— The Apple IIGs Buyer's Guide

Here is a partial list of the many features you' ll find:
~ Print font samples for reference
~ A graphic interface makes it easy to use
~ Handles fonts up to 255 points — that's big!
~ Change your mind? No problem — just "Undo" !
~ Includes a free disk of fonts to get you started right away
~ Smoothing helps eliminate the jagged edges on larger fonts
~ Open multiple fonts to make copying a character between fonts a snap
~ Easily create pre-styled fonts (e.g. bold and italic) to make them look their best
~ Convert fonts f rom Macintosh, and to a nd f r om the f o l lowing fo rmats:

BeagleWrite (MultiScribe), all versions of Print Shop, Publish It!, and Printrix

Suggested retail is only $39.95

Start making your best impression — buy Font Factory GS today!

Requires: Apple IIcs with 768K memory and at least one 3.5" disk drive

Also includes: GS/OS, Out To Launch, and Disk Initia.lizer

Seven Hills e ven i s
o 5 4 038 40305 o

Tallahassee, Florida • 904-575-0566



Font Factory GS

C ongratulations on y ou r p u rchase of Fon t Factory GS! Be s u r e t o
complete and return the postage-paid registration card so we can notify
you as new versions of this program become available.

Read this manual to learn all about using Font Factory GS to its fullest.
This manual is divided into three main sections:

The Getting Star ted section guides you t h rough o ne- t ime s teps,
including making working copies of Font Factory GS.

The Guided Tour section guides you through the basic, steps for using
Font Factory GS.

The Reference section contains detailed in fo rmation about Font
Factory GS.

In addition, the Appendices section contains information about Font Family
Numbers, Technical Information, and documentation for "Out To Launch,"
a small program launcher that's included free with Font Factory GS.

Enjoy!
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S About Seven Hills Software
Save 29 Width 54

Save As 30 Window Menu 45 No Copy Protection
Scaling a Font 19, 34 Windows We don't believe in copy protection — all it does is impair the honest user's

Character Window 50Scrolling Character Area 52 ability to use software to its ful lest. W e s t r ive to provide high quality
Font Window 48 products at reasonable prices. We hope you will support our efforts by

Shadow 38 Window Titles 45 not allowing your family or friends to copy this software.
Shifting a Character 51 Working Copy 7, 17

Shortcuts See Command Keys Postage-Paid Registration
Show Clipboard 45

Be sure to complete and return the postage-paid registration card so we
Show Test Window 45 can notify you as new versions of this program become available.

Slot Four 5 Updates are always reasonably priced.

Slot Settings 5

Smooth 40, 44 Questions and Comments
Startup Device 8, 17 We always welcome feedback — if you have any questions, comments, or

Startup Slot 5 suggestions for improving this product, please let us know! I n addi t ion,
we would like to hear your ideas for new programs.

Steps 3

Style 29
Contacting Us
For orders and product information call (904) 575-0566 from 9 a.m. to

Tools 51 5 p.m. ET, Monday-Friday.

U For technical questions about a specific product call (904) 576-9415 from
11 a.m. to 5 p.m. ET, Monday-Friday.

Underline 38
Contact us electronically for fastest written communication:

Undo 32
America Online, AppleLink, GEnie: SevenHills

V
CompuServe: 75300,1743

Version Number 26 FAX: (904) 575-2015
View Menu 38 To contact us the "old-fashioned way," write to:

Seven Hills Software
2310 Oxford Road
Tallahassee, FL 32304-3930
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0
Image Size 52 Open Font 29

Install Fonts 37 Open-Apple Keys See Command
Keys

Instructions 3
Origin 53

Italic 38
Other Settings 6

Out To Launch 8, Appendix C
Keyboard 3, 52

Outline 38
Keys 3

Page Setup 30
Leading 48, 53

Paste 32

Pencil 51

Memory 3, 6 Plain 38

Menus Point Size 53
Apple 26
Character 42 Print 3 31

Edit 32 QFile 28
Font 39 Quick Keys See Command Keys
View 38
Window 45 Quit 21, 31

Missing Symbol Character 49

Mouse 4, 5 RAM Disk 6

Moving a Character 51 Rename Fonts 37

N Resizing a Font 19, 34

Name 28 Rotate Left 40, 44

NDAs 6 27 Rotate Right 40, 43

New Desk Accessories 6 27

New Font 28

Number of Defined Characters
49

Index 3



Command Keys 25 About Font Factory GS
5-Control-Esc 27
CA (Save As) 30 Edit Character 34, 52 Font Factory GS™ was developed to answer the need of those who want

to create their own fonts and change fonts that already exist. Font Factory
5B (Bold) 38. Edit Font 33

GS runs on an Apple IIGS, but the fonts it produces can be used on any
QC (Copy) 32 Edit Menu 32 Apple as long as the software you are using supports "standard I IGS
QE (Edit Character) 34 fonts", T hese fonts can be used w i th p rograms l ike AppleWorks GS,
5F (Edit Font) 33

Edit Missing Symbol 35 GraphicWriter III, TimeOut SuperFonts and Platinum Paint.

QI Otalic) 38 Editing Options 51 Font Factory GS cannot create or edi t PostScript or out l ine fonts; i t i s
QN (New Font) 28 Eraser 51 meant only for creating classic Apple IIGS "bitmap" fonts.
QO (Open Font) 29 Our goal was to make Font Factory GS the best font editor and to make it
CP (Print) 31 F

valuable to you personally. By making a quality program available at a
CQ (Quit) 31 Family Number 28 reasonable price and by not copy-protecting the disk, we think we have
5S (Save) 29 succeeded. We hope that you support our efforts and encourage future

File Menu 28
QT Plain) 38 updates and products by not allowing your family or friends to copy Font

QU (Underline) 38 Flip Horizontal 39, 43 Factory GS. To borrow a phrase, "Just say no."

5V (Paste) 32 Flip Vertical 39, 43 This manual and the software (computer program) described in i t a re
CW (Close) 30 Font Info 35 copyrighted with al l r ights reserved. N o p a r t o f the Font Factory GS
QX (Cut) 32 software or documentation may be r eproduced, stored in a r e t r ieval
CZ (Undo) 32 Font Manager Appendix B system, or t ransmitted, in an y f o r m o r b y a n y m e ans, mechanical,

Font Menu 39 photocopying, r ecord ing o r o t h e rw ise, w i t hou t t h e pr i o r w r i t t en
Control Panel 5, 27 permission of Seven Hills Software Corporation.

Font Window 48, 52
Convert Fonts 36 Apple, IIGS, GS and GS/OS are trademarks of Apple Computer, Inc.

Copy 32, 37 Font Factory GS © 1989-91 IDirectPage],Bochum.
Font Factory GS is a trademark of Seven Hills Softv are Corporation.

Copy Protection 7 GEnie 29 All rights reserved.

Copyright 7 Grid Lines 42

Create New Point Size 19, 34 Guides 42, 53

Cut 32 H
0 Hand 51

DC Printer 27 Hardware Requirements 3

Delete 37 Home 52, 52

Descent Line 53

Desk Accessories 26

Disk Initializer 27
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Index

This index attempts to reference items in this manual by as many topics as
possible. If you are looking for a particular topic and can't find it, please
let us know so we can incorporate it in the next printing of the manual.

3x Magnification 42 CDAs 27

4x Magnification 42 Character Menu 42

8x Magnification 43 Character Origin 53

Character Window 50

A2-Central Font Clearinghouse Check Startup Device 8, 17

29 Choose Printer 27

About Font Factory GS 26 Classic Desk Accessories 27

Apple (4) Menu 26 Cleanup Font 39

Apply Style 41 Clear 33

Ascent Line 53 Clipboard 32

Close 30

Backup Disks 7 Close All 30

Base Line 53

Bold 38

Brush 51

Index 1



Error Handling
Out To Launch requires GS/OS, otherwise a "GS/OS required" message
will be shown. Table of Contents
The startup disk must be available at program startup and shutdown to
load and save your list. I f i t can't f ind ' /System, then you wil l be
prompted to insert the System disk.

Any disk error while loading your custom list of applications presents a
message "Problem loading. Error $ww44" (it is not an error to have no list
at all). It is possible to get a memory error during the load; if so, an "out Getting Started Section
of memory" message is shown and the remainder of the load is aborted.

Things You Need To Know .
When saving the list, if the disk is write-protected you will get a message

Hardware Requirementsand a chance to try again. A n y o t her d isk error presents a message
Keys on Your Keyboard"Problem saving. Error $w4'ew."
Steps .

3 3 3 3

The program you are trying to launch is verified to be available, otherwise Mouse Terms
you get a "Can't find program" message and a chance to swap disks. Preparing Your Apple IIGS 5
I f there's not enough room t o ad d a n i t em you w i l l ge t an " ou t o f Control Panel Settings . 5
memory" message, and the item is not added to the list. Check Your NDAs . 6

Making Working Copies . .... 7
Installing Onto 3.5" Disks . . 8
Installing Onto A Hard Disk Drive .. 12

Guided Tour Section
Starting Font Factory GS 17

Working With Fonts . 19
What Is A Font? ... 19
Opening A Font . 19
Editing A Character . 20
Printing The Font . ... 21
Quitting Font Factory GS ... 21
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Reference Section
The Command Buttons

Menus 25
Command Keys' . 25
4 (Apple) Menu 26 Launch Item

About Font Factory GS 26
Desk Accessories . 26 Launch Item launches the highlighted item, unless it is a "dummy l ine" (a

File Menu 28 line with no application attached — see Add Item).

New Font , 28
Open Font . 29 Launch Other
Save . 29
Save As 30 Launch Other displays the standard "get file" dialog box for you to choose

Close 30 a program t o l a u nch ( o n l y F o l ders, P8 System f i l es, and G S / OS

Close All . 30 applications are displayed).

Page Setup . 30
Print . 31 Add Item
Quit 31

Edit Menu 32 Add Item displays the standard "get file" dialog box for you to choose an

Undo 32 application to add to the l ist (only Folders, P8 System files, and GS/OS

Cut applications are displayed).

Copy After selecting an appl ication, a second dialog box appears to let you
Paste 32 customize the name of the application as it appears in the list (this does
Clear . 33 not rename the file). See Edkt Item for information.
Edit Font , 33
Edit Character 34 You can create a "dummy l ine" for f i l ler or spacing by holding down the

Edit Missing Symbol . 35 Option key when you c l ick the Add I tem bu t ton. T h i s sk ips the f i le

Font Info . 35 selection and goes directly to the editing dialog box.

Convert Fonts 36
Install Fonts 37 Remove Item

View Menu . 38
Plain 38 Remove Item deletes the highlighted item from the list.

Bold ..... 38
I talic .............. . . . 38 Edit Item
Underline 38
Outline .......... 38 Edit Item opens a dialog box to let you edit the name of the highlighted
Shadow 38 item as it appears in the list. You are allowed up to 31 characters of free­

Font Menu 39 form entry (anything you can type is acceptable). The items in the list are
Cleanup Font 39 sorted in ascending ASCII order.
Flip I-Iorizontal .. . 39 The optional code is not displayed in the l ist. I t i s used if you want to
Flip Vertical 39 group i tems t ogether o n t h e l i s t ( f o r e x a mp le , t o g r o u p g r a ph ic
Rotate liight 40

applications together you could code each application with a "g").
Rotate aft . 40
Smooth 40 Clicking the OK button (or pressing Return) stores any changes. Clicking
Apply Style 41 the Cancel button aborts the process.
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Character Menu . ... 42
Grid Lines ... 42

The Menus Guides . 42
3x Magnification ... 42
4x Magnification .. 42

4 (Apple) Menu 8x Magnification ... 43
Flip Horizontal 43

About Out To Launch — Shows version number, credits, and general Flip Vertical . 43
information. Rotate Right 43

Rotate Left ... 44
File Menu Smooth

Window Menu 45
Shut Down — Ejects all "ejectable" disks and shows the message "You may Show Clipboard 45
now switch off your Apple IIGS safely." This shut down is configured so Show Test Window 45
it will not reset RAM disks in case you decide to Restart. Window Titles 45

Quit — Quits Out To Launch and returns to the previous program Windows 47
(presumably another launcher). If there is no previous program, then the The Font Window
System launches Out To Launch again. Leading . 48

Number of Defined Characters 49

Edit Menu The Character Window . ... 50
Editing Options

This menu is provided for desk accessories. Guides 53

Appendices
Appendix A — Font Family Numbers

Appendix B — Technical Information

Appendix C — Out To Launch

Index
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Appendix C
Out To Launch

Out To Launch is a simple "program launcher" that is meant to replace the
program-launching function of Apple's Finder, thus saving a lot of disk
space. It can launch applications and it provides access to the New Desk
Accessories on the 4 (Apple) menu. This is especially useful with an
NDA such as Disk Access, which provides all the functions of the Finder,
plus other functions such as Find File and Show File.

Out To Launch uses about 7K on disk and in memory, and it requires an
Apple IIGS with at least 512K memory (ROM 01 or higher) and GS/GS. It
should be named Start and placed in the System folder of your startup
disk (it is possible to run it from another launcher, but that would defeat
its purpose).

Out To Launch C-1



The "best-fit font algorithm" tries several options in its attempt to produce
a font that is as close to the requested font as possible. I f the particular
steps interest you, they are:

1) The Font Manager first looks for a font with the same family and size
and style that partially matches the desired style. I f there is more than
one such font, the one with the most styles is used. Getting Started

2) I f a font is not found in step 1, the Font Manager looks for a font with
the same family number, twice the size, and a partially matching style.
If there is more than one such font, the one with the most styles is
Used.

3) I f no fonts are found in step 2, the Font Manager looks for a font with We know you are anxious to start using Font Factory GS, but please read

the same family number, half the size, and a partially matching style. this section f i rst because it leads you through several important steps
In the case of a tie, the font with the most styles is used. which you need to do only once:

4) I f the Font Manager still hasn't found any suitable font, it looks for a • Lea rn ing conventions and terminology
font with the same family number, a larger size than requested, and a • Get t ing your IIGS ready to start a IIGS-specific program
partially matching style. I f more than one such font is found, the one
with the smallest size is used. I f more than one such smallest size is • Mak i ng working copies of each disk
found, the font with the most styles is used. I'he next section teaches you how to use Font Factory GS by letting you

5) I f t here's still no match, the Font Manager looks for a font w ith the experiment with its features. The last section covers every aspect of Font
same family number, a smaller size than the requested size, and a Factory GS, organized for reference. It is the best place to look when you
partially matching style. I f more than one such font is found, the one need added information or help with a particular feature.
with the largest size is used. I f m ore than one such largest size is
found, the one with the most styles is used.

6) I f there is no font with the requested family number, the system font
is selected.

NO?E In steps I-5 it is noted that in case of a t ie the font with the most
styles is used. Of course, a tie may still occur (with two fonts that have the
same number of, but different, styles enabled). In such a case, a font in
memory is selected over one on disk. If this rule still doesn't determine the
font to use, the last found font is used.

B-2 T e chnical Information



Appendix B
Technical Information

This appendix contains technical information that is no t necessary to
know in order to use Font Factory GS; it is provided for those who are
interested. For more technical information regarding fonts (as wel l as
many other topics), refer to the Apple IIGS Toolbox Reference books.

The Font Manager
The Font Manager manages all the fonts on your Apple IIGS. When you
start your computer with a desktop application (such as Font Factory GS's
startup disk), the Font Manager looks in the System/Fonts directory and
catalogs al l the f o nts and f on t f a m i l ies that are ava i lable . T o be
recognized as a font, the file must be type $C8.

In addition to the fonts that reside on disk, one or more fonts could reside
in ROM. Currently, only Shaston.8 is a ROM font. Shaston.8 (the "system
font" ) is used in menus, dialog boxes, and so on, thus it is present in ROM
to guarantee it is always available.

In order for the Font Manager to di fferentiate between fonts, each font
contains the following information:

• Th e font name (e.g. Geneva)

• Th e family number (e.g. 3)

• Th e point size (e.g. 12)

• Th e style (e.g. Plain)

All fonts that share the same family number are called a font family. The
font name and number should always agree within a font family (i.e. two
different font names should not use the same font family number, nor
should the same font name use two different font family numbers).

The Font Manager keeps track of fonts via the Font ID, which is a number
that contains the family number, the point size and the style. W hen a
program (such as GraphicWriter III) requests a particular font in a
particular size and a particular style, the Font Manager either provides the
requested font (if it is available in the System/Fonts folder), or it creates a
new one by using the "best-fit font algorithm".

T echnical Information B - 1



Things You Need To Know

Hardware Requirements
To use Font Factory GS you need:

• An A p p le I IGS with at least 1MB of memory

• On e 3.5" disk drive

• Fo nt Factory GS includes GS/OS — the "disk operating system". GS/OS
requires internal ROM version of at least 01 — when you turn on the
computer, i f the bo t tom o f th e screen does no t show a v e rs ion
number, contact your authorized Apple dealer for an upgrade.

• To p r i n t samples of the fonts you create, you need any pr inter that
works with a standard IIGS printer driver. Included are printer drivers
for the Apple ImageWriter I, II, and LQ, and Epson FX-compatible
printers.

I f you w ish t o p r in t t o a L aserWriter, we assume you h ave the
appropriate printer drivers available to you. NOTE Font Factory GS is
n ot meant fo r c r eat ing LaserWriter fon ts . Y o u c a n p r i n t t o a
LaserWriter but the characters will not be "LaserWriter quality".

If you wish to print to a Hewlett-Packard DeskJet or LaserJet, you can
purchase and use the Independence pr inter dr iver package from
Seven Hills Software.

Keys on Your Keyboard
Keys on the keyboard are referred to by th e n ame p r in ted on t hem
(Delete, Option, A, etc.). The Command key is shown as 5.

Steps
Steps you should follow are indented and numbered. For example:

1. Learn Font Factory GS.

2. Create neat new fonts.

Things You Need To Know 3



Appendix A
Mouse Terms Font Family Numbers
This manual uses four terms to describe the different ways you can use
the mouse: The following table shows the range of font family numbers that the A2­

Central Font Clearinghouse uses in assigning numbers:
C1icking means quickly pushing down and releasing the mouse button
while the mouse remains motionless. Some uses of clicking are to select a Font Family Number

Hexadecimalcharacter or turn dots in a character on and off. Decimal F~amil Name
0-1 $0000-$0001 System Font

Double-C1icking means quickly clicking twice. D ouble-clicking is 2 $0002 New York
3 $0003 Genevacommonly used as a shortcut for some action. For example, double­ 4 $0004 Monaco

dicking on a character opens the character editing window. 5 $0005 Venice
6 $0006 London

Pressing means holding the mouse button down while the mouse 7 $0007 Athens
remains motionless. The most common use is pressing on a scroll bar's 8 $0008 S an Franc i s c o
arrow to cause the document to scroll until the mouse button is released. 9 $0009 Toronto

10 $000A <reserved>
Dragging means holding the mouse button down, moving the mouse to a 11 $000B Cairo

new position and finally releasing the mouse button. Common uses are 12 $000c Los Angeles

drawing lines, choosing a menu item and moving or resizing a window. 13 $000D Z apf Di ngbat s
14 $000E Bookman
15 $000F H elvet i c a N a r ro w
16 $0010 P alat i n o
17 $0011 <reserved>
18 $0012 Zapf Chancery
19 $0013 <reserved>
20 $0014 Times
21 $0015 H elvet i c a
22 $0016 Courie r
23 $0017 Symbol
24 $0018 T alie s i n
25-32 $0019-$0020 <reserved>
33 $0021 Avant Gar de
34 $0022 N ew Centur y S c h o o l book
35-42 $0023-$002A R eserved f o r A p p le fonts
43-239 $002B-$00EF R eserved f o r M a c i n to sh f o n t s
240-255 $00FO-$00FF R eserved/Used by S t y leware { C l a r i s )
256-991 $0100-$03DF <reserved>
992-1055 $03EO-$041F R eserved/Used by S t y leware { C l a r i s )
1056-31743 $0420-$7BFF <reserved>
31744-33791 $7COO-$83FF A2-Cent r a l F o n t Cl ea ringhouse r a n g e
33792-65279 $8400-$FEFF <reserved>
65280-65532 $FFOO-$FFFC R eserved f o r A p p l e s ystem f o n t s
65533 $FFFD Chicago
65534 $FFFE Shaston
65535 $FFFF No Font

4 Thin gs You Need To Know F ont Family Numbers A - 1



Preparing Your Apple IIGs
There are several things you must do in order to use any software that is
written specifically for the Apple IIGS. These are common settings so it is
likely that your IIGS is already prepared to run Font Factory GS.

Control Panel Settings
The first step is connecting the mouse, then using the Control Panel to
correctly set various options:

1. While the computer is off, plug the mouse into your keyboard.
2. Turn the monitor on.

3. Hold down the Option key while you turn on the computer's
power switch.

4. When you see several choices on the screen, release the Option
key.

5. Press 1 to enter the Control Panel.

Slot Settings
Enter the Slots display:

1. Press Up Arrow until Slots is highlighted, then press Return.

Slot 4: Make sure that Slot 4 indicates you are using the Mouse Port:

2. Press Down Arrow until Slot 4 is highlighted.

3. I f Slot 4 reads Your Card, press Right Arrow to change the option
to read Mouse Port.

Startup Slot: I f yo u c h o ose, you can te ll the I IGS to s tart loading
programs from the 3.5" disk drive:

4. Press Down Arrow until Startup Slot is highlighted.

5. Press Right Arrow unti l the desired slot number appears (if you
have the 3.5" disk connected to the back of the IIGS, the number
is 5).

Save the Slot Settings:

6. Press Return to save the current settings for the Slots display.

P reparing Your Apple IIGS 5



RAM Disk Setting
RAM disks use memory that could be used by the program. Font Factory
GS needs 1MB memory to operate, so verify that there is at least this much
memory free for it to use:

1 . A t t h e C o n t ro l Panel, press Down A r row u n t i l RAM D isk i s Appendices
highlighted, then press Return.

2. Press Down Ar row to h i gh l ight Maximum RAM Disk Size (or
"Select RAM Disk Size" on the newest IIGS model).

3. As a general rule, IIGS-specific software works better with more
memory available to it . T hus, we suggest setting the RAM Disk Appendix A — Font Family Numbers
size to 0K. I f the Maximum RAM Disk Size needs to be reduced, Appendix B — Technical Information
press Left Arrow until its size is acceptable.

Press Return to save the current RAM Disk settings. Appendix C — Out To Launch

5. I f you changed the Maximum RAM Disk Size, turn the computer
off. NOXE Changes to the RAhf Disk display don't take effect until
the computer is turned off ((3-Control-Reset does not work; you
must turn the computer off if you changed this setting). If you
turn the computer off, wait 15 seconds before turning it back on.

Other Settings
This manual assumes that you already have your printer connected and
working with the Apple IIGS. If not, refer to the documentation that came
with your pr inter to connect i t and to set any necessary Control Panel
settings.

A popular p r i n ter con f iguration i s a n I m ageWriter p r in ter d i rectly
connected to the Printer Port on the Apple IIGS. For this configuration,
the control panel setting for Slot 1 should be Printer Port and every printer
port setting should have a checkmark beside it.

Check Your NDAs
New Desk Accessories are stored in the System/Desk.Aces folder of your
startup disk. When you start Font Factory GS each New Desk Accessory
sets aside memory for i ts own use; memory acquired by a New Desk
Accessory cannot be used by Font Factory GS. I f yo u h ave just 1MB
memory you should consider removing any installed NDAs to give Font
Factory GS the most memory possible.

6 Prep aring Your Apple IIGS



• Th e r ed hor izontal line that intersects the base line is used to set the
w idth of the current character (the next character's origin w i l l be

Making Working Copies
placed at the intersection of the black base line and the red w id th
l ine). To adjust width, move the mouse pointer over the red width Before proceeding, protect the original disks by
line (the pointer changes to a arrow pointing left and right), then drag making sure t ha t t hey a r e w r i t e -protected!
the line to its new location. Look at the bole in tbe upper-right corner of
Every character has the same width in a fixed-width font each of tbe original disks. The disk is wri te­

protected if you can see through tbe bole. I f
you can't see through the bole, slide tbe tab so

Each character c an have a different width in a proportional font you can.
Whenever you purchase software you should make a working copy of
each original disk. NOTE: Font Factory GSis not copypro tected, but it is
cop~gh t ed . P lease do not make copies for your family or fr iends — every
illegal copy you see is a vote against fr iendly software and Jor copy­
protection and higher prices.

After making your working copies (either on a hard drive or on $.5" disks)
you should store the original disks in a safe place so if a problem ever
develops with a work ing copy another can be made from the or iginal
disk. If a problem ever develops with an original disk, contact Seven I-Iills
Software for replacement information.

54 Win dows: The Character Window Making Working Copies



Guides
Installing Onto 3.5" Disks

The character window contains several guides that help you draw uniform
This section describes installing Font Factory GS onto 3.5" disks. I f you characters:
are installing Font Factory GS onto a hard disk drive, skip to the section
titled "Installing Onto A Hard Disk Drive." Ascent Line

The origin of the
Apple's "Finder" is a program that lets you do "housekeeping" tasks, such Character Origi o next character will
as copying disks and deleting files. We' ll use the Finder to make working Base Line be positioned here.copies of the supplied disks.

1. Insert the disk labeled Or ig inal " D i sk.1" in to the startup disk Descent Linedrive. Leading Line
2. Turn on the monitor and computer (if the computer is on already,

hold 5-Control down and press Reset). The 3.5" disk drive will • Th e b lack horizontal line is the character's base line. The bot tom of

come on and begin loading our Out To Launch program launcher. each character (excluding tails on letters like p) is placed on the base

NOTE: If you did not set your 3.5" disk drive to be the startup slot, line.

the computer will try to start up from some other disk drive. If you • The b l ack vertical line is the character's origin (the point used as a
get the message "Check Startup Device," hold Control and press reference location for drawing the character).
Reset. At the prompt type PR¹5 (assuming your 3.5" disk is in slot
5) and press Return. • The p u r p le l ine above the base l ine is the ascent l ine. T h i s l i n e

indicates the top of the tallest character in the font.
3. W hen the Out To Launch window appears, select "The Finder"

and click the Launch Item button. • Th e f i rst purple line below the base line is the descent line. This l ine
indicates the bottom of the character that extends farthest below the

When the Finder is finished loading, you wil l see a blue desktop with a base line. I f the font leading is set to 1 or h igher, a second purple
menu bar at the top of the screen, an Original. Disk.1 disk icon at the top­ line will be below the descent line. The number of dots between the
right of the screen, and a Trash can icon at the bottom-right of the screen. descent line and the leading line wil l be equal to the leading f igure

you set.
Initializing Disks Strictly speaking, the total number of dots between the ascent line and

Before proceeding, make sure you can see through the descent line should equal the point size, although you wil l f ind fonts

hole in the upper-right corner of the original disks! ( including some supplied by App le) where there are more or less
dots.

To make working copies of Font Factory GS on 3.5" disks, you need two
initialized (but otherwise blank) 3.5" disks.

The Finder has the ability to initialize disks, but for simplicity we' ll use the
Disk Initializer desk accessory. Disk Initializer is provided free with Font
Factory GS.
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Editing Other Characters 'I'o use Disk Initializer,

After you are finished with the current character, there are three ways to 1. Choose Disk Initializer from the 4 me nu (move the pointer over
edit a different character without closing the character window: the 4 (A p p le) menu, press and hold down t he mouse button,

drag down to h ighlight Disk In i t ializer, then release the mouse
Below the window's title bar is a small scrollable area that displays 10 button).
characters of the system font. The current character you are editing is
highlighted in green. T o e d i t another character, use the arrows to The following dialog box appears:
scroll the desired character into view then click on it.

Press a key on the keyboard and the character associated with that llisk Initializer v1.1
Coppripht 1989,91 bp Seven !lit ls Software Corp.

key will appear. Written bp Steve Stephenson

Click the Home tool to bring the character's font window to the front,
then open another character. I n t h e f on t w i ndow, the currently
selected character is h i gh l ighted i n g r een . Ch a racters that a re
currently open for editing are "grayed out".

If you made any changes to the current character, you will be asked if you Howe the new disk: FIGS
want to in tegrate the changes into the font . C l i ck Yes to keep your
changes, No to discard your changes, or Cancel to continue editing the

Cancelcurrent character. Initialize

Image Size The Disk Initializer dialog box
The Image Size displays the current width and height of the character. The scroll box displays the slots and drives that have a 3.5" or 5.25" disk
These numbers are adjusted as you add and r emove dots f rom the drive. To initialize a disk,
character.

2. C l ick on the slot/drive you want to use for initializing (usually 3.5"
disk drives are located in s lo t 5) . NOT E: l 'o r t he best speed
performance you should in i t ia l ize the disk in the same slot and
drive that the disk wi l l be used in . F o r e x a mple, if yo u a r e
initializing a startup disk then you should init ialize the disk in the
startup disk drive. l f you are in i t ia l iz ing a data d isk then you
should initialize the disk in the data disk drive.

Insert a blank disk.

4 . Typ e t h e n ame fo r t h e n e w d i s k ( t h e f i rs t d isk i s n a m ed
" Font. Factory.GS"). T he na m e c a n no t b e lo n ge r t h a n 1 5
characters, and it must begin with a letter and contain only letters,
numbers, and periods.

5. Cl ick the Ini tialize button. NO TE: Th is button is active only if a
valid disk name is entered.

After you cl ick In i t ialize, the disk in the slot and dr ive you specified is
checked. If the disk is blank it wil l be initialized immediately. I f the disk
is not blank you w i l l be asked to conf irm your decision to in i t ialize it .
Never initialize an original disk!
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After the disk is initialized it wil l be ejected and you wil l be told whether
the initialization was successful. I f i n i t ialization fails for a disk, discard Editing Options
that disk and use another one. I f init ialization was successful, apply a disk Tools
label and write the. appropriate name on it.

The Hand tool is used to shift the character to a new position (in effect
Repeat steps 2-5 to create one disk with each of the following names: changing the character's origin). Position the hand pointer on top of the

El Font. Factory.GS (done in step 4) character, and hold down the m ouse but ton. A re c tangle shows the
overall size of the character. Drag this character rectangle to the desired

D F. ~.2 position and release the mouse button.

After you have initialized and applied a label to the two disks, click Cancel The Penci1 tool is used to add and remove dots. To draw dots, point to a
to return to the Finder. blank location on the grid and cl ick. To erase dots, point to an existing

dot and click. You can continuously draw or erase dots if you hold the
mouse button down as you drag.Copying the Original oisks
The Brush tool is used to f i l l in l a rge areas quickly. T he b rush draws

Before proceeding, make sure you can see through the three dots across by two dots down. Yo u can continuously draw dots if
bole in the upper-right corner of tbe original disks! you hold the mouse button down as you drag.

Now we' ll use Apple's Finder to make an exact copy o f each o f t he The Eraser tool is used to erase large areas quickly. The eraser removes
supplied disks: three dots across by two dots down. You can continuously erase dots if

1. Insert the disk you want to copy onto (one of the disks that you you hold the mouse button down as you drag.

initialized and hand-labeled). The f i rst "destination disk" is the The Home tool is used to bring the character's font window to the front.
disk hand-labeled Font Factory GS so insert that disk. This is useful when several windows are on the screen at once. Cl icking

2. I nsert the disk you want to copy from (one of the original disks Home wil l activate the font window that contains the character you are
supplied with Font Factory GS). Th e f i rst "source disk" is the editing, and it w i l l h ighl ight that character. To r e turn to the character
original disk labeled Original "Disk.1," so insert that disk (if you window either choose it from the Window menu, or choose Edit Character
have only one 3.5" disk drive, you wil l have to eject your hand­ from the Edit menu.
labeled disk to make room for the original).

3 . D rag the o r ig inal d isk i con onto the h and-labeled disk i con:
Position the arrow pointer over the original disk icon, hold down
the mouse button, drag onto the hand-labeled disk icon (it turns
black) then release the mouse button. The f i rst copy is made by
dragging the Original. Disk.l icon onto the Font. Factory.GS icon.

4 . The F inder asks i f yo u w an t t o r e p lace the contents o f t h e
destination disk with the contents of the source disk. Cl ick OK to
proceed. XO' IE. If you get a message stating that the destination
disk is u r i te-protected, you ar e t r y ing to c opy in th e w r o ng
direction — click the Cancel button and go back to step 3, making
sure you drag the source disk icon onto the destination disk icon.

During the copy process the Finder may ask you to insert a particular disk.
Find the desired disk, insert it and click OK to continue.
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When the Finder is finished copying the disk,

The Character Window 5. D rag the source disk icon onto the Trash icon. T h is ejects the
disk and removes its icon from the "desktop".

There are three ways to open a character window from a font window: 6 . D rag the destination disk i con i n to the T rash to e ject i t and
remove its icon from the desktop.

Double-click on the character.
Repeat steps 1-6 for each of the following disks:

Click on a character to select it, then choose Edit Character from the
Edit menu. Drag: On to :

Choose Edit Missing Symbol from the Edit menu to edit the missing g O r iginal. Disk.1 Fon t . Factory.GS
symbol character. P F o nt. Disk.2 Fonts.2

File Edit Character Window
:$CI Venice 14: I = chr(70) Removing the Finder

c5 6P Q ' 4 8 C D E F G H I J K I Ieioge size is 9, 11 In order to create some extra disk space for storing fonts, you might want
to remove the Finder from your working copy of Font Factory GS. Follow
these steps if you wish to remove the Finder:

1. Insert your disk hand-labeled Font Factory GS.

• $$ $ $ $ $ 2. C l ick on the Font. Factory.GS disk icon to select it, then choose
• $
• $
• $ Open from the File menu.
$ $ $ $ $
• $
• $
• $ 3. D rag the Finder icon into the Trash.
• $

4. D rag the Font. Factory.GS disk icon into the Trash to eject the disk
and remove its icon from the desktop.

Quitting the Finder

The character wi ndow (grid lines are turned off)
Let's quit Apple's Finder and return to Out To Launch:

1. Choose Shut Down from the Special menu.
The character window contains an expanded version of the character you
opened. The title of the window shows which character you are working 2. C l ick to select the "Return to launching application" option.

with (the font, the character and its "ASCII" value are displayed). Below 3. C l ick the OK button to return to Out To Launch.
the title is a line that contains tools, a scrollable character area, and the 4. W hen Out To Launch appears, choose Shut Down from the File
current image size. menu. NOTE S ee Appendix C for more information about using

Out To Launch.A smaller window within the character window shows how the character
looks in all the standard styles (plain, bold, italic, underline, outline and Skip to the Guided Tour section to begin using Font Factory GS.
shadow). This smaller window can be moved and resized: To move i t ,
position the pointer over it (the pointer changes to a hand); then drag the
window to its new location. To resize it, drag its grow box.

When a character window is active (in front of al l other windows), the
Character menu is available. This menu contains options that apply only
to the single character being edited.
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Number of Defined Characters
Installing Onto A Hard Disk Drive

While IIGS fonts can contain up to 256 characters, they usually contain
Installing Font Factory GS on a hard disk drive is just a matter of copying less than that. The number of defined characters reflects the number of
some files from each of the supplied disks to your hard drive. Th is characters that have actually been drawn.
section describes which files to copy and where to put them. To begin,
start the computer with your hard drive, then launch Apple's Finder.

A "missing character" symbol is displayed (usually just a box) for
characters that have not been drawn.

Because you have a hard drive, we assume you are familiar with file
management and using the Finder, so that is not covered in-depth here. If
you need more information on using the Finder, refer to the manuals that
came with your Apple IIGS.

Installing Font Factory GS
Insert the disk labeled Original "Disk.1" i nto a drive and open it. D r a g
the Font. Factory.GS folder onto the hard drive icon.

After the Font. Factory.GS folder is copied, drag the Original. Disk.1 icon
into the Trash to eject it and remove it from the desktop.

Installing Fonts
You may want to install some of the supplied fonts onto your hard drive.
If so, first open the System folder on your hard drive and locate the Fonts
folder. Next, insert the disk labeled Font Disk Number 2 and open the
Fonts folder on that disk. Finally, drag the font files you want to use into
the Fonts folder on your hard drive.

After you have copied all the fonts you want, drag the Font. Disk.2 icon
into the Trash to eject it and remove it from the desktop.
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Desk Accessories
The Font Window

Desk Accessories are stored in the System/Desk.Aces folder of your hard
File Edit View Font Window elf lve.

Venice 14
Leading in points: 0 !! umber of defined characters is 152 We have provided a new desk accessory named "Disk Initializer" that lets

I= 0 tl= 2 tl= 3 t!= 4 5= 5 you initialize 3.5" and 5.25" disks from within a program like Font Factory
GS. To install Disk Initializer onto your hard drive, first open the System
folder on your hard drive and locate the Desk.Aces folder. Next, insert the
disk labeled Original " D isk.2," open the System folder, then open the
Desk.Aces folder on that disk. F inally, drag the Initializer.NDA icon into

= 32 ! = 33 II 3 4 8= 35 6= 36 8= 37 6= 38 '- 39 the System/Desk.Aces folder on your hard drive.

After you have copied the Disk In i t ializer, drag the Original. Disk.1 icon
into the Trash to eject it and remove it from the desktop.

La= 64 B= 65 B= 66 C= 67 B= 68 E= 69 F= 70 G= 71 NOTE I ' on t Factory GS has been tested extensively. I f y ou experience
strange problems with Font Factory GS, remove all desk accessories, then
add them back one at a time to see if a particular accessory is causing the
problem. If the problem still exists with no accessories installed, please send
a report to Seven Ilills' technical support.

The font window

The font window contains all 256 possible characters of a font. The t i t le
of the window shows the name and size of the font you are working with.
Below the title is a line that shows the leading (in points) of the font and
the total number of def ined characters. Each character of the font i s
displayed within the font window.

When a font window is active (in front of al l other windows), the View
and Font menus are available. These menus contains options that apply
to the entire font being edited.

Leading
Leading is the amount of blank white space that is added to the bottom of
every character in the font. Leading is usually about 10% of the point size
(for example, a 14 point font usually has 1 point leading).

You can change the leading by clicking on the leading number and typing
a new value (in points). Press Return to re-display the entire font with the
new value.
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Windows
There are two main windows used in Font Factory GS: the Font window
and the Character window. The Font window displays all the characters
of a font; the Character window displays a single character for editing.

Both windows have all the features of a standard window:

Title Bar>

Close Box Zoom Box

Scroll Bars —.:,:'.;::
I

Grow Box

Click the close box to close the window.
Point to the window's title bar and hold down the mouse button
to drag the whole window to a new location.

Drag the grow box to resize the window.
Click the zoom box to expand the window to full-screen size and
to revert back to the size you set.

Use the scro11 bars to scroll different areas into view.
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This section is a tutorial that leads you through the essential features of
Font Factory GS.

When you have completed the steps in this section you will have a good
working knowledge of Font Factory GS. See the Reference section for
detailed information about a particular menu command..



Window Menu

Show Clipboard
Choose Show Cl ipboard f rom the Window m enu t o v iew the current
contents of the Clipboard. A l l s ix styles (Plain, Bold, I talic, Underline,
Outline and Shadow) of the last cut or copied character are placed on the
Clipboard.

Choose Close from the File menu to close the Clipboard's window (or
click the close box).

Show Test Window
Choose Show Test Window from the Window menu to display some
sample text. This window is useful to see what a particular font looks like
in actual use.

When the Test Window is active, three menus appear: Font, Size, Style.
Use the mouse to highlight the text you want to change, then make font,
size, and style choices using those menus. NOTE: You can use the Choose
Font option on the Font menu to change two or three of the options at a
time.

Fonts available in the Fonts folder can be used. If you are editing a font
and want to test it, follow these steps:

1. Save the font into the Fonts folder (in the System folder of your
startup disk).

2. Choose Close All from the File menu to close all open windows
(saving changes as desired).

3. Choose Install Fonts from the Edit menu.
4. C l ick the Reinstall Font Manager button ( this restarts the Font

Manager and causes the new font to be recognized).
5. C l ick Done to close the Install Fonts dialog box.

6. Choose Show Test Window from the Window menu.

7. H i ghl ight some text and choose the new font, size, and style.

Window Titles

Choose a window t i tle from the Window menu to br ing that window to
the front (thus making i t active). The number of w indows that can be
open at the same time depends upon the amount of memory available.
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Rotate Left Starting Font Factory GS
Choose Rotate Left f rom the Character menu to r o tate the d isplayed If you installed Font Factory GS on a hard drive, we assume that you are

character 90' to the left. familiar with starting a program from the hard drive.

To begin using the working copy of the 3.5" Font Factory GS disk, follow
these steps:

L I n sert the Font Factory GS disk into the startup 3.5" disk dr ive.

The results of Rotate Left NOTE When you are asked to insert a disk, insert your working
copy of that disk — keep your original disks in a safe place.

Smooth 2. Turn on your monitor and computer (i f the computer is already
on, hold 5-Control down and press Reset). The 3.5" disk drive

Choose Smooth f rom th e Character menu t o s m ooth the d i splayed will come on and begin loading the program launcher. NOTE I f
character. you did no t set your 3 .5" d isk dr ive to be the startup slot, the

computer will try to start up from some other disk drive. If you get
$mooth the message "Check Startup Device", hold Control dou n and press

K ininnn ~O ~ Cence i Reset. At the prompt type PR¹ 5 (assuming your 3.5" disk is in slot
Oeioic ~2 ~ OK 5) and press Return.

The Smooth dialo b
When Out To Launch appears, select "Font Factory GS" and click

g ox the Launch Item button.
Smoothing has d e faul t m i n i mum an d w e i gh t v a l ues o f 6 and 2 After the program is loaded, the "About Font Factory GS" dialog box is
respectively. Using these default values usually creates the best smoothing
results.

displayed with the program version number and copyright information.
Click the mouse button or press any key to continue.

NOTE Smoothing is done by a special technique that may or may not
benefit a particular character. If, after smoothing a character, you decide
that you'd rather work from the non-smoothed version, choose Undo from
the Edit menu.

44 Menu s : Character Menu Starting Font Factory GS 17



8x Magnification
Choose 8x Magnif ication f rom the Character menu to v iew o r e d i t a
character at 8 t imes its actual size. The 8x Magnification view does not
display Grid Lines.

Flip Horizontal
Choose Flip Horizontal from the Character menu to flip the displayed
character left to right. NO TE S o me characters (such as H) wil l look the
same after flipping.

The results of Flip Horizontal

Flip Vertical
Choose Flip Ver t ical f rom the Character menu to f l i p t h e d i sp layed
character top to bottom. NOTE: Some characters (such as H) will look the
same after flipping.

The results of Flip Vertical

Rotate Right
Choose Rotate Right from the Character menu to ro tate the displayed
character 90' to the right.

• •

The results of Rotate Right
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Working With Fonts
Character Menu
T his menu is only p resent when a character window i s ac t ive. T h e What Is A Font?commands on the Character menu apply only to the single character that
is displayed. A font is a co l lection of re lated characters (letters, symbols, numbers,
To apply the Flip, Rotate, Smooth, or Style options to all the characters in pictures, etc.) which are of a predetermined style and size. A "standard
the font, c l ick the Home i con in th e character window t o b r ing t he I IGS font" i s a s t ructured f i le that contains in formation about each
character's font window to the front, then choose the option from the Font character in a font.
menu. Up to 256 characters can be defined and stored in a IIGS font (typically the

first 128 characters are for "normal" characters and the second 128 are for

Grid Lines "special" characters that are not pictured on the keyboard). For characters
that are not d rawn, a special "missing symbol" character is displayed

Choose Grid Lines from the Character menu to turn the character grid off (usually a rectangle).
and on.

When editing a character at 4x magnification, the grid displays as vertical
and horizontal dotted lines. Turning the grid off removes these lines and Opening A Font
just the character is displayed.

There are two ways to open a font for editing. I f the font you want to edit
is in the System/Fonts folder of the startup disk, you would choose Edit

Guides Font from the Edit menu. I f the font you want to edi[ is on another disk,

Choose Guides from the Character menu to turn the character guides off you would choose Open from the File menu.

and on. Let's edit one of the fonts in the Fonts folder of the startup disk:

When editing a character, the character guides display the ascent l ine, 1. Choose Edit Font from the Edit menu and the standard "choose
base line, descent l ine and a l ine below the descent l ine to show the font" dialog appears.

amount of leading the font has. 2. Select the font you want to edit (choose any font for this guided
tour).More information on gu ides is p rovided in " The Character Window"

section. 3. Select the size you want to edit. To edit an existing size, choose
the size from the scroll box. To create a new point size, type the
new number in the "Size:" box.

3x Magnification
Click OK to open the font.

Choose 3x Magnification from the Character menu to v iew o r e d i t a
character at 3 times its actual size. The 3x Magnification view does not Opening a font presents a new w indow that d isplays all 256 possible

characters (tliey are displayed in 8 rows of 32 characters each). Below thedisplay Grid Lines.
title bar is a line that shows the font leading (white space between printed
lines) and the total number of defined characters.

4x Magnification
Choose 4x Magnification from the Character menu to v iew o r e d i t a
character at 4 times its actual size. The 4x Magnification view is preferred
because each dot appears round when Grid Lines are visible, When Grid
Lines are not. visible, each dot is displayed as a square.
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NO7Z Sm o othing is done by a special technique that may or may no t
b enefit a particular character. I f you have done more editing thanj u s t

Editing A Character creating a new point size by using Edit Font, you may want to save your
n on-smoothed version because smoothing the u h o le f on t c a n no t b e

In the font window there are two ways to open the character you want to undone. If smoothing doesn't work uell for this particular font, close the
edit. You can either click on the character to select it then choose Edit font ui thout saving any changes then re-open the version you saved prior
Character from the Edit menu, or you can double-click the character. to using the Smoothing command.

1. Open any character now. NO 7E I f y ou want to edit the missing
symbol character, choose Edit Missing Symbol from the Edit menu.

Apply Style
A new window is opened that contains a large version of the character
that was selected. The t i t le of the window shows you which character C hoose Apply Style f rom the Font menu to a p p ly a s t y le to a l l t h e

you are working with. characters in the font. Because this command affects the entire font, Font
Factory GS warns you that it cannot undo the operation.

The dotted lines that fill the screen form a grid that shows where dots can
be placed. You can turn these grid l ines off and on by choosing "Grid Applying a style is useful for creating a pre-styled font. Instead of drawing

Lines" from the Character menu. the style from scratch you can apply the desired style and use it as your
starting point.

The solid l i nes are gu ides that help yo u d raw e ach character to a
consistent size (Ir ides are explained fully in the Reference section). Apotu Stute

Simply point and click to change the character. To add dots, point to a Stale B o l d H Ad j ust Font ID
~ I tal ic

blank location on the grid and click; to remove dots, point to a dot and C7 Underline ~ Can cel
click. You can continuously draw or erase dots if you hold the mouse Outline
button down while dragging. Other tools are discussed in the Reference O Shadow
section. The Apply Style dialog box

As you change the character, a smaller window shows how the character Use the checkboxes to indicate the styles that you want to apply. I f you
looks in all the standard styles (plain, bold, italic, and underline, outline, are creating a pre-styled font, leave the "Adjust Font ID" option checked.
and shadow). This smaller window can be moved and resized. To move This option automatically adjusts the Font ID to m atch the styles you
the window, position the pointer over it (the pointer changes to a hand) checked (for example, if you apply "bold, italic" the Font ID information
then drag the window to its new location. To resize it, drag its grow box will be changed to say the font is "bold, italic" ).
in the bottom right corner.

On the Character menu are commands that you can use to help draw
characters.

2. Experiment with edit ing the character: C l ick and drag to draw
and erase dots, and try the F l ip and Rotate options from the
Character menu.

When you are finished editing the character choose Close from the File
menu (or press 5W or click the close box). You are asked-if you want to
integrate the new character into the font. C l ick Yes (or press Return) to
keep the new character, No to ignore the new character, or Cancel if you
want to continue working with the character.
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Rotate Right
Printing The Font

Choose Rotate Right from the Font menu to rotate every character in the
font 90' to the right. Because this command affects the entire font, Font To print a sample of the font:
Factory GS warns you that it cannot undo the operation. Choose Control Panel f rom the 4 (Appl e ) m e nu a nd c l i c k

DC Printer to verify that the proper pr inter port and pr inter are
selected. NO ' IK Fon t F a c tory GS is not m eant for c reat ing
LaserWriter fonts. You c a n p r i n t t o a La s e rWri ter but t h e
characters will not be "Laser Writer quality".

The results of Rotate Right
2. C l ick the close box to close the Control Panel window.

Rotate Left 3. Choose Page Setup from the File menu to verify the page setup is
correct. I f a "Vertical Condense" option is available, it should be

Choose Rotate Left from the Font menu to rotate every character in the checked to obtain the best print quality.
font 90' to the left . B ecause this command affects the entire font, Font Choose Print from the File menu. To p r int a true representation
Factory GS warns you that it cannot undo the operation. of the font, choose Fast or Standard quality and cl ick OK (Best

quality does not print the font you are viewing...to achieve Best

. Ch' quality the printer driver uses a font that is 2, 3, or 4 times larger
than the font you view on the screen).

The results of Rotate Left The sample prints the font's name, size, and family number in Shaston 16,
then prints two sample sentences and all the characters available in the
font. The style of the pr inted font is the same as the style(s) that are

Smooth checked on the View menu.

Choose Smooth from the Font menu to smooth every character in the font.
Because this command affects the entire font, Font Factory GS warns you
that it cannot undo the operation. Quitting Font Factory GS
Smoothing especially useful after you have scaled a font to a larger size­ Choose Quit from the File menu whenever you want to quit Font Factory
smoothing can save you time by doing some of the touch-up. Addi t ional GS. Any open windows will be closed just as if you chose Close from the
smoothing can be done by hand using the tools in the Character window. File menu (so you wil l be asked if you want to save changes if any were

$mooth made). Because you were only practicing with the font in this Guided
Tour you should not save any changes you made.

ifininnn ~5 ~ t encei

Keieht ~2 ~ KK When the Out To Launch window appears, choose Shut Down from the
File menu to shut the computer down. NO I Z Se e Appendix C for more

The Smooth dtalog box information about using Out To Launch.

Smoothing has d e faul t m i n i mum an d w e i gh t v a l ues o f 6 and 2
respectively. Using these default values usually creates the best smoothing
results.

40 Menu s : Font Menu Working With Fonts 21



Font Menu
This menu is only present when a font window is active. The commands
on the Font menu apply to every character in the font.

To affect only a single character, open the single character then choose an
option from the Character menu.

Cleanup Font
Choose Cleanup Font from the Font menu to resize the height of the font
after editing. NOTE: You do not have to choose this option; u hen a font is
saved it is automatically cleaned up.

While you are editing a font, Font Factory GS automatically adjusts the
font height to accommodate the tallest character. However, if the tallest.
character is made shorter, the overal l f on t h e ight i s n o t r e adjusted
downward unti l the font is saved. Choose this command to adjust the
height without saving the font.

Flip Horizontal
Choose Hip Horizontal from the Font menu to fl ip every character in the
font left to r ight . B e cause this command affects the entire font, Font
Factory GS warns you that it cannot undo the operation. NO T E: Some
characters (such as H) will look the same after flipping.

The results of Flip Horizontal

Flip Vertical
Choose Flip Vertical from the Font menu to flip every character in the font
top to bottom. Because this command affects the entire font, Font Factory
GS warns you that it cannot undo the operation. NOTE: Some characters
(such as H) will look the same after flipping.

The results of Flip Vertical
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View Menu
This menu is only present when a font window is active. Reference
Plain
Shortcut: CT

Choose Plain from the View menu to view the font you are editing in
Plain text (i.e. with no special styles — any special styles are turned ofO.

This Reference section describes every feature found in Font Factory GS.
This section is organized strictly for reference — use it to learn'about a

Bold specific feature or to refresh your memory on how to perform a specific

Shortcut: CB task.

A particular topic or command can be found in the Table of Contents or
Choose Bold from the View menu to view the font you are editing in bold

Indextext. Choose this command again to turn off this option.

Italic
Shortcut: CI

Choose Italic from the View menu to v iew the font you are edit ing in
italic text. Choose this command again to turn off this option.

Underline
Shortcut: 5U

Choose Underline from the View menu to view the font you are editing in
underline text. Choose this command again to turn off this option.

Outline
Choose Outline from the View menu to view the font you are editing in
outline text. Choose this command again to turn off this option.

Shadow
Choose Shadow from the View menu to view the font you are editing in
shadow text. Choose this command again to turn off this option.
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Install Fonts

Choose Install Fonts from the Edit menu to install or remove fonts in the
System/Fonts folder of the startup disk, or to edit the Font ID information
of a font.

Install Fonts

~: Font.Disk.2:Fonts Sgstem/Fonts Folder
AHADOR.11CongQ ASL.Fingers.18 0 4rmonk.24

D 4SL.Fingers.24 Delete D 4vant.Garde.10
Q ASL.Fingers.36 9 Avant. Garde.12
Q 4SL.Fingers.48 Info D Avant. Garde.14
Q 4bbegDeco.14 Done 9 Avant. Garde.18
Q AbbegDeco.28 IO 4vant.Garde.24
D Aberdeen.12 BOOKHA)I.9

~d r ie r ( Nore ) Reinstall Font Hanager
~deo Folder ~Crore (RHtXHI

The Install Fonts dialog box

Use the scroll box and buttons on the left side of the dialog box to access
fonts not located in the System/Fonts folder. The scroll box on the right
side shows all the fonts currently installed in the System/Fonts folder.
Each button acts upon the highlighted font, whether it is in scroll box on
the left or the right.

To copy a font into the System/Fonts folder, find and select the font in the
left scroll box, make sure the direction button is pointing to the right ( — ->)
and click Copy. T o c op y f o nts fr om th e S ystem/Fonts folder to t he
location you specify on the left, change the direction button so it points
left (< — -). To rename a font before copying it, type the new name in the
lower-right of the dialog box, then click Copy.

To delete a font, select the font in one of the scroll boxes and click Delete
(you will be asked to verify that you really want. to delete the font).

To edit the font information. for a font, select the font in one of the scroll
boxes and c l ick In f o . NOT E. Re fer to t he " Font I n fo" section fo r
information about the Font Info dialog box.

To create a new folder in the left scroll box, type the folder name in the
box below the "Reinstall Font Manager" button and click New Folder.

If you make any changes to the fonts in the System/Fonts folder, you
should click the Reinstall Font Manager button. ' I 'his button is active only
if no other w indows are open (to act ivate it , c l ick Done to c lose this
dialog box, choose Close All from the File menu, then choose Install Fonts
again).
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MenusConvert Fonts
Choose Convert Fonts from the Edit menu to convert fonts created by M enus contain all the commands available with Font Factory GS. T h e
other programs for use as a standard IIGS font, or to convert standard IIGS titles of all the menus are shown in the menu bar at the top of the screen.

fonts into fonts that can be used with other programs. Different menu t i t les appear depending upon wh ich w indow is active.
F or example, w he n n o w ind o w s a r e o p e n t h e me n u b a r r e a d s

Convert Fonts File Edit W indow", but when a font window is active the menu bar
has two new menus titles: "Gt File Edit Vi ew F o nt Wi n dow".

Apple I I GS Convert
Apple Hacintosh Apple Hacintosh
BeagleHrite Done Beagleh!rite

T o see the commands available in a m e nu , pu l l the menu down b y

Hew Print Shop Hew Print Shop pointing to its title and pressing the mouse button. When a command is
Old Print Shop Old Print Shop dim it is not available at the moment.
Print Shop GS Print Shop GS

Printrix This section is organized by the menu titles and menu commands.
Publish It! Publish It!

The Convert Fonts dialog box Command Keys
To convert fonts, Many commands have keyboard shortcuts that let you give the command

'l. I n t h e scrol l box on the l e ft , choose the format you w ant: to without using the mouse to pull down a menu and choose the command
convert from. name. T h ese shortcuts are l isted to th e r i gh t o f t h e c o r responding

2. I n the scroll box on the r ight, choose the format you want to commands in the menus. For example, pull down the File menu and you
convert to. w ill see several keyboard shortcuts listed: C N f o r New Font, CO f o r

3. C l ick Convert and you are asked to choose the font to convert. Open, and so on.
After selecting the font, click Open. To use a keyboard shortcut, hold down the Command key (5) and press

4. D epending on the conversion you specified, you may be asked to the letter listed on the menu. The Command key has a hollow apple and
give further information. a cloverleaf on it and it is located between the Option key and the ti lde

5. A f ter a successful conversion takes place, you are asked to name key at the lower-left of the keyboard, NO lE Yo u do not have to hold the
and save the converted font. Type the name, specify the location Shift key dou n u:hen using a keyboard shortcut.
and click Save.

To convert more fonts, repeat steps 1-5; click Done when you are finished
converting fonts.
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Edit Missing Symbol
4 {Apple) Menu

Choose Edit Missing Symbol f rom the Edi t menu to ed i t the m issing
The 4 menu conta.ins the standard About command and New Desk symbol character.
Accessories. While you can draw up to 256 characters, it is likely that some characters

will not be drawn in the font. When displaying or printing those blank
About Font Factory GS characters, a "missing symbol character" is shown instead of a blank

space. Usually the missing symbol character is just a box, but you can
Choose About Font Factory GS from the 4 menu to display the program edit it to be something different.
version number and copyright information.

Font InfoFonryocloryGS .o.o
Choose Font Info from the Edit menu to change a font's name, number,

4 font editor for the Apple llOS size, or style information. This option is available only when a font
window is active.

Written bg Wilfried Ricken.
Copgright 1989-1991[BirectPage].Buchan. Font Info

Published bg Seven Hills Software Corp. F ont Bane i ym i
Font Factory OS is a tradonark
of Seven Hills Software Corp. Fanilg Huber ~5

All rights reserved. Size ~14 P oint s

(Press ang keg or click the noose to continue) Stgle OBold
Q Itolic

The About Font Factory GS dialog box O Underline Cancel
O Outline
O Shadow OK

Desk Accessories The Font Info dsalog box

When you start the computer, each desk accessory uses some memory Only change this information if you know what you' re doing. I f you
that cannot be used by Font Factory GS. change one font be sure to make the same change to other sizes of that

font.NOTE: Font Factory GS has been tested extensively. I f y ou experience
strange problems with Font Factory GS, remove all desk accessories, then NOTE: Changing the Size number in the dialog box does not actually
add them back one at a time to see if a particular accessory is causing the change the size of the font; itj ust changes the size that the Font Manager
problem. If the problem still exists with no accessories installed, please send uses to refer to this font. To resize an existing font, see the "Edit Font"
a report to Seven Hills' technical support. section.
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Resizing a Font New Desk Accessories

The Edit Font command lets you scale a font to create a new size. New Desk Accessories (NDAs) appear under the 4 (Apple) menu. NDAs
are stored in the System/Desk.Aces folder of your startup disk ( f i letype

For example, if you have a font only in 12 point, you can create a new $B8).
size of that font by selecting the font in the scroll box, then typing the
new size in the Size box. The new font will be scaled (created) from the To use an NDA, choose it from the 4 (Apple) menu like any other menu
12 point font, then you' ll just need to touch it up instead of drawing the command. For information about using a particular NDA you must refer
new size by hand. to the documentation that came with it.

When you open the Edit Font dialog box you can select a particular font Control Panel
and point size from the scrolling lists. To create a new size of an existing Control Panel lets you change various system-related options, including
font: your printer setup. Refer to the documentation that came with your Apple

1. H ighl ight the font in the list. IIGS for information about changing the printer type and connection
2. Instead of selecting a point size from the list of available sizes, method.

type the desired size in the "Other" box. Disk Initializer
3. Click OK.

Disk Initializer is provided free with Font Factory GS. I t a l lows you to
The IIGS Font Manager then attempts to create the new font size. I f there initialize 3.5" and 5.25" disks without having to quit the program you are
is sufficient memory available, the Font Manager will be able to create the using.
requested font and a new font window will be displayed. I f the font
appears "jagged," the Smooth command might help (see "Smooth" in the Classic Desk Accessories
Font Menu section). To access any Classic Desk Accessories (CDAs) stored in the System/

If there is not enough memory to hold the new font, the Font Manager DeskAccessories folder of your startup disk (filetype $B9), hold 5-Control
will return a font that contains errors. I f Font Factory GS states that the down while you press and release Esc.
font contains errors, the font will not be useable. NOTE: Even if you have For information about using a par t icular CDA you m us t re fer to t h e
8NB of memory in your computer the Font Manager still might not be able documentation that came with it.
to create a font of the requested size if memory has been 'fragmented."

Edit Character
Shortcut: CE

Choose Edit Character from the Edit menu (or double click on a character)
to edit the selected character.

You can edit the character by clicking to add or remove dots from the
character, as well as using the special editing options available on the
Character menu.

More information on editing characters is provided in" "The Character
Window" section.
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ClearFile Menu
Choose Clear from the Edit menu to erase the selected character.

The File menu contains commands that let you create, open and pr int
fonts. If the font window is active, you are warned that Clear cannot be undone;

i f you cl ick Continue, the selected character wil l be removed from the
font.

New Font
I f the character windo~ is active, Clear quickly erases all the dots in the

Shortcut: 5N character so you can start with a blank grid. I n th e character window,
Clear can be undone so you don't see a warning.

Choose New Font from the File menu to create an entirely new font.

Font Into Edit Font
F ont Home Em t z i

Shortcut: 5FFamilU Number ~0

Size ~12 P oint s Choose Edit Font from the Edit menu to change any font that is currently

St Ule Bold installed in the System/Fonts folder of the startup disk. NO TE: You can
O Italic use the Install Fonts command on the Edi t menu to add f o nts to the
D Underline Cancel System/Fonts folder without quitting Font Factory GS (see "Install Fonts" ).
O Outline

Shadow
Font:

The New Font dialog box
Silicon ValleiiWhen creating a new font you must specify the name, family number, size Smallville

and style for the font. Together, the font family number, size and style SUmbol
information comprise the Font ID n u m ber that i s used by the "Font Tines
Manager" (see Appendix A for examples of existing font numbers). UC-Cosno Black

StUle
Name H Plain Size

The font name should be no more than 25 letters long. As a convention, Bold 16
Italic 32

the name should contain letters only (no numbers or symbols). Underline Cancel
Family Number Outline

O Shadow
The font family number in theory can be any number from 0 to 65535
($0000-$FFFF), but there are restrictions on this number. For example, if The Edit Font dialog box
you choose a number that duplicates the font family number of an existing NOTE The look of this dialog box might change in future versions of
font, the Font Manager can get confused. Care must be taken to avoid Apple's system software, but the function will be similar.
duplicate numbers.

Normally fonts are drawn in th e "P lain" style and the Font Manager
If you intend to use the new font only on your computer, you can pick simulates the special styles (bold, underline, italic, outline and shadow),
any arbitrary number that isn't used by other fonts you have (numbers in but if you have drawn a font in a particular style, click the appropriate
the $9000 range should be a good choice for your own personal use), but check box to edit that style.
i f you intend to sell the font or re lease it into the public domain, you
should request a u n ique f ont: family n u mber f rom A 2-Ceniral Font
Clearinghouse.
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The Font Clearinghouse maintains a database of font family numbers and
can assign a unique number to a font you wish to distribute. There is no

Edit Menu charge for the service — their reward is e l iminating a font numbering
conflict and the confusion it causes in the Apple community.

The Edit menu contains commands for using the Clipboard and editing
fonts and characters. You can contact the A2-Central Font Clearinghouse through the A2-Central

Roundtable on the GEnie on-line service. You can also write to the Font
The Clipboard is a temporary holding area. Any character that is cut or Clearinghouse c/o Mark Collins, 2511 Pebble Valley Road, Waukesha, WI
copied is held on the Cl ipboard unti l another cut or copy command is 53188. See Appendix A " F on t Family Numbers" fo r the nu mbering
issued. To see what is currently on the Clipboard you can choose Show arrangement they have established.
Clipboard from the Window menu.

Style
When a character is cut o r c o p ied, al l s ix s ty les (Plain, Bold, I tal ic,
Underline, Outline and Shadow) are placed on the Clipboard. Normally fonts are drawn in the "P lain" style and the Font Manager

simulates the special styles (bold, underline, italic, outline and shadow).
By specifying the style for the new font, you can draw a special version of

Undo a particular font (for example, you can draw a bold version). I f a bo ld

Shortcut: CZ version is created, the Font Manager uses it. instead of simulating bold.

Choose Undo from the Edit menu to undo the last change you made. Open Font
Shortcut: 50Cut

Shortcut: CX Choose Open Font from the File menu to open an existing font. Several
fonts can be open at one time; the total amount depends on the amount

Choose Cut from the Edit menu to remove the selected character from the of available memory.
font and place it on the Clipboard. When you open a font for editing, several checks are performed to verify

the font information is valid. A new f ont w indow w i l l appear if a font

CopY appears to be valid. I f an error is detected you can usually instruct Font
Factory GS to flx it by clicking the appropriate button.

Shortcut: DC
To create a new point size of an existing font, see Edit Font in the Edit

Choose Copy from the Edit menu to put a copy of the selected character Menu section.
on the Clipboard.

Save
Paste

Shortcut: CS
Shortcut: CV

Choose Save from the File menu to save the font onto the disk. As you
Choose Paste from the Edit menu to replace the selected character with make changes to a font, you should save periodically to avoid losing your
the character that is on the Clipboard. work in the case of a power failure.

32 Menu s : Edit Menu Menus: File Menu 29



Save As Print

Shortcut: QA Shortcut: CP

Choose Save As from the File menu to save a copy of the font under a Choose Print from the File menu to print a sample of the font in the active
different name or at a different location on your disk. font window. The "Print" dialog box typically lets you specify how many

copies to print, the quality setting to use, and so on (the actual choices

Close depend upon which printer driver is selected).

To print a true sample of the font, choose Fast or Standard quality and
Shortcut: CW dick OK (Best quality does not print the font you are viewing...to achieve

Choose Close from the File menu (or dick the window's close box) to Best quality the printer driver uses a font that is 2, 3, or 4 times larger than

dose the active window. the font you view on the screen).

If the active window is a character window you are asked if you want to The sample prints the font's name, size, and family number in Shaston 16,
integrate the changes you made into the font. Click Yes to replace the old then prints two sample sentences and all the characters available in the
character with the new one, No to leave the character as it was, or Cancel font. The style of the pr inted font is the same as the style(s) that are

to continue editing the character. checked on the View menu.

If the active window is a font window, you are asked if you want to save
the changes you made to the font. Click Yes to save the changes, No to Quit
abandon the changes, or Cancel to continue working with the font. Shortcut: 5Q

Close All Choose Quit from the File menu to quit working with Font Factory GS.

Any open windows will be dosed just as if you chose Close from the File
Choose Close All from the File menu to dose all the open windows. This menu, then Font Factory GS returns to the previous application (usually
command doses each window just as if you chose Close repeatedly. the "Out to Launch" program launcher or Apple's Finder).

Page Setup
Choose Page Setup from the File menu to verify or change printing
options.

The "Page Setup" dialog box typically lets you specify information about
the paper size you want to use (specific options depend upon which
printer driver is selected). If a "Vertical Condense" option is available, it
should be checked to obtain the best print quality.
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