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Kangaroo 

Congratulations on your purchase of Kangaroo! Be sure to complete and 
return the postage-paid registration card so we can notify you as new 
versions of this program become available. 

A kangaroo is good at jumping ... just imagine if he could jump for you! 
He'd jump from disk to disk, bringing in his pouch the list of folders and 
files you use often ... 

Hop! You're inside ":Hard.Disk:Business:Plans:Smith.Proposal:" 
Hop! You're inside ":Hard.Disk:System:Fonts:" 
Hop! You're inside ":Floppy.DiskPersonal:Letters:To.Jim:" 

Our KangarooTM is a friendly little pet who gives you instant access to 
your commonly-used folders and files. And he's also full of many other 
surprises! He can find files, create new folders, delete files, change file 
information, and format disks, without ever having to return to the Finder. 
Although he requires little attention, please read this documentation to 
learn all about the care and feeding of your future best computer friend. 

Our goal was to make Kangaroo a very useful productivity tool and to 
make it valuable to you personally. By making a quality program 
available at a reasonable price and by not copy-protecting the disk, we 
think we have succeeded. We hope that you support our efforts and 
encourage future updates and products by not allowing your family or 
friends to copy Kangaroo. To borrow a phrase, "Just say no." 

This manual and the software (computer program) described in it are 
copyrighted with all rights reserved. No part of the Kangaroo software or 
documentation may be reproduced, stored in a retrieval system, or 
transmitted, in any form or by any means, mechanical, photocopying, 
recording or otherwise, without the prior written permission of Seven Hills 
Software Corporation. 

Apple, IIGS, GS and GS/OS are trademarks of Apple Computer, Inc. 

Kangaroo © 1991-1992 Seven Hills Software Corporation and BrainStorm 
Software. Kangaroo is a trademark of Seven Hills Software Corporation. 

All rights reserved. Printed in the U.S.A. 



Thanks To ... 
Etienne Petitjean, Louis van Proosdij Duport, and the rest of 
BrainStorm for writing this fantastic program. Man Deatherage and 
the other supportive people at Apple Computer. AU of our user group 
"Partners" for telling people about our products. And you, for 
supporting our IIGS publishing efforts! 

Limited Warranty 
SEVEN HILLS SOFTWARE CORPORATION'S LICENSOR(S) MAKES NO WARRANTIES, EXPRESS OR 
IMPLIED, INCLUDING WITHOm LIMITATION THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE, REGARDING THE SOFTWARE. SEVEN HILLS SOFTWARE 
CORPORATION'S LICENSOR(S) DOES NOT WARRANT, GUARANTEE OR MAKE ANY REPRESENTATIONS 
REGARDING THE USE OR THE RESULTS OF THE USE OF THE SOFTWARE IN TERMS OF ITS 
CORRECTNESS, ACCURACY, RELIABIUTY, CURRENTNESS OR OTHERWISE. THE ENTIRE RISK AS TO 
THE RESULTS AND PERFORMANCE OF THE SOFTWARE IS ASSUMED BY YOU. THE EXCLUSION OF 
IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT 
APPLY TO YOU. 

IN NO EVENT WILL SEVEN HILLS SOFTWARE CORPORATION'S LICENSOR(S), AND THEIR DIRECTORS, 
OFFICERS, EMPLOYEES OR AGENTS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR 
INDIRECT DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS INFORMATION, AND THE LIKE) 
ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE EVEN IF SEVEN HILLS SOFTWARE 
CORPORATION'S LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE 
SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL 
OR INCIDENTAL DAMAGES, THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU. SEVEN HILLS 
SOFTWARE CORPORATION'S LICENSOR'S LIABILITY TO YOU FOR ACTUAL DAMAGES FROM ANY 
CAUSE WHATSOEVER, AND REGARDLESS OF 'THE FORM OF THE ACTION (WHETHER IN CONTRACT, 
TORT (INCLUDING NEGLIGENCE), PRODUCT LIABILITY OR OTHERWISE), WILL BE LIMITED TO $50. 

IN NO EVENT WILL SEVEN HILLS SOFTWARE CORPORATION, ITS DIRECTORS, OFFICERS, EMPLOYEES 
OR AGENTS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR INDIRECT DAMAGES 
(INCLUDING DAMAGES FOR LOSS OF BUSINESS INFORMATION, AND THE LIKE) ARISING OUT OF 
THE USE OR INABILITY TO USE THE SOFTWARE EVEN IF SEVEN HILLS SOFTWARE CORPORATION 
HAS BEEN ADVISED OF THE POSSIBIUTY OF SUCH DAMAGES. BECAUSE SOME STATES DO NOT 
ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL 
DAMAGES, THE ABOVE LIMITATIONS MAY NOT APPLY TO YOU. SEVEN HILLS SOFTWARE 
CORPORATION'S LIABIUTY TO YOU FOR ACTUAL DAMAGES FROM ANY CAUSE WHATSOEVER, AND 
REGARDLESS OF THE FORM OF THE ACTION (WHETHER IN CONTRACT, TORT (INCLUDING 
NEGLIGENCE), PRODUCT LIABILITY OR OTHERWISE), WILL BE LIMITED TO $50. 

About Seven Hills Software 

No Copy Protection 
W~ .don't believe in copy protection-all it does is impair the honest user's 
ablhty to use software to. its fullest. We strive to provide high quality 
products .at reasonabl~ pnces. We hope you will support our efforts by 
not allowmg your farruly or friends to copy this software. 

Postage-Paid Registration 
Be sure .to complete and return the postage-paid registration card so we 
can notlfy you as new versions of this program become available. 
Updates are always reasonably priced. 

Questions and Comments 
We always welcome feedback-if you have any questions comments or 
suggestions for improving this product, please let us kno~! In addition, 
we would like to hear your ideas for new programs. 

Contacting Us 
For orders and product information call (904) 575-0566 from 9 a.m. to 
5 p.m. ET, Monday-Friday. 

For technical questions about a specific product call (904) 576-9415 from 
11 a.m. to 5 p.m. ET, Monday-Friday. 

Contact us electronically for fastest written communication: 

America Online, AppleLink, GEnie: SevenHills 

CompuServe: 75300,1743 

FAX: (904) 575-2015 

To contact us the "old-fashioned way," write to: 

Seven Hills Software 
2310 Oxford Road 
Tallahassee, FL 32304-3930 



.......................... ............... ............... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ........................... .................................. . . . . . . . . . . . 

I 

Table of Contents 

Getting Started 
3 .............................. ............................ 4 

Things You Need To Know ............... .. .............................................. . 
11' g Kangaroo ...................................... ................. ...... . . . 5 

Ins,. m .......................................... 6 
Activating Kangaroo ... ..... ...... .... ....... ...... ..... ..... ....... ..... ......... 7 

. dT r .......................................................................................... 8 
Gutde au ........ oo's Options ..................... .. ............................. 11 V· . ng Kangar .............. . 

leWl . chic Menus .................... ............................. 12 
Using Hlerar ............................... .......... .. 

Preferences ................................ : ........................................... : .............. 12 

Folde" and F'Z:cti~gAF~id;;; •...................•••••••••••••••••••••••••............... :l Manually ................. .. ........ .. 
Hopping Ar~und .......... :::::::: ..................................... ::: ...... :: ............ 14 
Direct Openlng ............. .. ........ .......... .. .... .. ........ ........... 14 

T Go From Here ............. .. .................... .. 
Whele Te~ser .................................................... .. 

Table of Contents 



Reference 
Folders ......................................................................................................... 17 

Files ............................................................................................................. 18 

Volumes ...................................................................................................... 19 

Options ........................................................................................................ 20 
Add Current Folder / Add Selected Folder .......... , ....... ..... .... .... ..... .... 20 
Add File ................................................................................................. 20 
Purge Folders ....................................................................................... 21 
Purge Files ........ ......... ............. ...... ..... .................. . . ............... . .......... .... 21 
Preferences ........................................................................................... 22 
Group Setup ......................................................................................... 25 
Help ...................................................................................................... 28 
About ..................................................................................................... 28 

OS Utilities .................................................................................................. 29 
Find File .................... ........................................................................... 29 
New Folder .......................................................................................... 31 
Delete ................................................................................................... 32 
Rename/Access ..................................................................................... 33 
Eject Disk .......................... ................................................................... 34 
Erase Volume ....................................................................................... 34 
Format Volume .................................................................................... 35 

Application Group ....................................................................................... 36 
Group Name ......................................................................................... 36 
Application Name ................................................................................ 36 

Common Questions and Answers .............................................................. 37 

Index 

ii Table Of Contents 

Getting Started 

We know you are anxious to start using Kangaroo, but please read this 
section first because it leads you through several important steps which 
you need to do only once: 

• Learning conventions and terminology 

• Installing Kangaroo onto your startup disk 

After this section is the Reference section which covers every aspect of 
Kangaroo. 



Things You Need To Know 

Requirements 
To use Kangaroo you need: 

• An Apple IIGS 

• A startup disk with System Software 5.0.4 (or later) installed. 

• One 3.5" disk drive 

• IIGS-specific programs that work with System Software 5.0.4 or later 
(e.g. AppleWorks GS, GraphicWriter III, Platinum Paint, etc.). 

Keys on Your Keyboard 
Keys on the keyboard are referred to by the name printed on them 
(Delete, option, A, etc.). The Command key is shown as d. 

Steps 
Steps you should follow are indented and numbered. For example: 

CD Use Kangaroo. 
@) Increase your productivity. 
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Installing Kangaroo 
Installing Kangaroo is easy ... just follow these steps: 

<D Start up your Apple IIGS using the startup disk that you normally 
use (either a 3.5" floppy disk, or a hard disk drive, which contains 
System Software 5.0.4 or later). 

When you reach the point where you can launch an application, 
® Insert the original "Kangaroo" disk into a 3.5" disk drive. 
@ Launch the "Install" program. 
@) When you are asked to do so, type your organization name 

(optional) and your full name, then click the Personalize button. 
The original Kangaroo disk must not be write-protected (you 
should not be able to see through the hole in the upper-right 
comer of the disk). 

Soon Apple's Installer window is displayed. The scroll box on the left 
side of the window contains the "scripts" that can be used to install 
Kangaroo. 

@ The "Full Kangaroo Installation" script is already highlighted, so 
just click the Install button and Kangaroo and its icons are copied 
to the disk that was used to start the computer.1 
NOTE: If there is not enough space for the Full Kangaroo 
Installation, select the Mini Kangaroo Installation script and click 
Install. If there still is not enough room, you'll need to delete some 
items from your startup disk in order to install Kangaroo. 

® After Kangaroo is installed successfully, click the Quit button to 
quit Apple's Installer. 

(/) Click the Restart System button to restart the computer. 
@ Eject the original Kangaroo disk and store it in a safe place. 

1 In addition to installing the Kangaroo.Icons into your Icons folder, 
these three files are installed into the System. Setup folder: 
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Kangaroo: The application itself (required). 

Kangaroo.Rez: Contains the Kangaroo help text and some graphics. 
It is not required to run Kangaroo; it can be deleted if you need the 
disk space and don't mind not having online help. 

Hierarchic: Provides hierarchic menu capability. It is required by 
Kangaroo, and may be required by other programs from Seven Hills 
Software and! or BrainStorm Software. 

Installing Kangaroo 

Activating Kangaroo 
After installation, Kangaroo is located in the System:System.Setup folder on 
your startup disk. Normally Kangaroo will be activated automatically 
whenever you start your Apple IIGS (an icon appears on the startup 
screen when it is loaded). Because you restarted the system after 
installing Kangaroo, it has been activated and is ready to use. NOTE: If 
Kangaroo does not load for any reason, an X will appear on top of the 
Kangaroo icon. 

Inactivating Kangaroo 
Usually you will want Kangaroo to be active so he can help you. But 
there are several ways to make him sleep: 

Really Short-Term: If Kangaroo was loaded at startup time, then later 
you dedde you don't want him to do anything, use the Kangaroo Classic 
Desk Accessory (CDA) to temporarily turn him off. To do this, hold down 
(j-Control and press Escape. Press the Down Arrow to highlight 
"Kangaroo Is On," then press Return to tum him off. Repeat this process 
when you want to tum him back on. 

Short-Term: To inactivate Kangaroo only during this use of your 
computer, hold down the Shift key (or the keys you spedfy ... see 
Preferences) when you start the computer. This keeps Kangaroo from 
loading on this startup only (an X will appear on top of the Kangaroo 
icon). 

Long-Term: You can inactivate the Kangaroo icon in the Finder. In the 
Finder, find the Kangaroo icon (in the *:System:System.Setup folder) and 
click once to select it. Hold down (j and press I to display information 
about this icon. Click the "Inactive" checkbox, then close the window. If 
he is already loaded, Kangaroo hangs around until the next time you start 
the computer. But after that he won't be loaded until you uncheck the 
"Inactive" box. 

Really Long-Term: In the unlikely event you want to kick Kangaroo 
completely out the door, delete the following files from your startup disk: 
Kangaroo, Kangaroo.Rez (if it's there), and Hierarchic2 (all in the 
System:System.Setup folder), Kangaroo.Prefs (in the System:Preferences 
folder), and Kangaroo.Icons (in the Icons folder). Also, please let us 
know why your startup disk wasn't a suitable home for our Kangaroo. 

2 Unless you have another application that uses hierarchic menus. 
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Guided Tour 
Kangaroo can show off only in IIGS-specific "desktop" applications, such 
as AppleWorks GS, GraphicWriter III, Platinum Paint, ShrinkIt-GS, Super
Convert and so on. 

G) In order to play with Kangaroo, start any desktop application you 
own. 

@) After the application is started, choose Open from the File menu 
(or some other option that presents an "Open" dialog box). 

A dialog box similar to the following will appear: 

Please se I ect til e to open. 
~ I!:l..s:.Letters (ProDOS) 
a Chris m 
o Chm.2 
o Fred 
o Jane 
o Kathy 
o Mike 
o MOIl 
CJ Old.Letters 

( 

( 
( 
( 

Yolume ) 

Open ) 
Close ) 
Cancel ) 

A standard "open" dialog box with Kangaroo 

This "StandardFile" dialog box should be familiar except for one new 
thing: Our friendly Kangaroo is displayed above the file list, to the left of 
the current path. 

N01E: Kangaroo works fine with System 5.0.4, but throughout this 
manual the example displays arefrom System 6. The displays using System 
5.0.4 will be similar to, but not exactly like, the displays in this manual. 
Also, the displays will vary depending upon which application you are 
using (most examples are using the "Teach" application that is provided 
with System 6). 

6 Guided Tour 

Viewing Kangaroo's Options 
The small Kangaroo icon tells you that he is alive and well. To actually 
use Kangaroo you need to poke him (gently, please): 

G) Position the mouse pointer over the Kangaroo icon, then hold 
down the mouse button. Kangaroo hops into action and displays 
its options: 

!::; rl)ldNS 
r::; nil'S 

Iii YolUlles 
S1I OPtions 
" OS Utilities 

Universal 
Teach 

Kangaroo's options 

Using a Kangaroo menu is like using the menu bar at the top of the 
screen. For example, to choose an option you drag the mouse down to 
highlight the option, then release the mouse button when your choice is 
highlighted. Also, items that do not apply are dim (e.g. Folders, Files). 

However, there is an important difference (besides the splash of color): 
Several of Kangaroo's menus are "hierarchical" (a fancy way to say that a 
"sub-menu" of choices will appear when you highlight a main menu item). 

A menu item has a sub-menu if it has a right arrow icon. In the example 
above, Volumes, Options, OS Utilities, and Universal all have sub-menus. 

Guided Tour: Viewing Kangaroo's Options 7 



Using Hierarchic Menus 
Using a hierarchic menu is similar to using a regular menu: You just 
highlight the option you want. Here's how: 

<D If the Kangaroo menu is not still displayed, position the mouse 
pointer over the Kangaroo icon, then hold down the mouse 
button. 

@) Drag the mouse down to highlight the Options menu item, and 
this sub-menu appears: 

C;; fl>ldt'rs 
[j fi lI~s 
iii Yohaes 

Add Current Folder 
Add File 

t--·---·-i Purge Folders 
Universol Purge Files 
Teoch Preferences ... 

I.....-----l 
Group SetuP ... 
Help .. . 
About .. . 

A bierarcbical menu. Note tbat a sub-menu 
can lead to otber sub-menus (Purge Folders, Purge Files). 

@ With the Options menu item still highlighted, drag the mouse 
directly to the right (do not drag up. or down off the Options 
menu item). NOTE: Soon we'll sbow you bow to tell Kangaroo to 
let you drag less precisely. 

® Once an item on the sub-menu is highlighted, drag down to 
highlight the About item. When the About item is highlighted, 
release the mouse button. 

You will see a dialog box similar to the following: 

Kangaroo A 

NOTE: If you bad to use tbe "Mini Kangaroo Installation" script tben a text 
version of tbis dialog box will appear. 

8 Guided Tour: Viewing Kangaroo's Options 

When you are ready to proceed, click the mouse button and a second 
dialog box with "credits" appears. Click the mouse button again and 
you'll see that Kangaroo is personalized for you! Click once more and 
you'll be returned to the "Open" dialog box. 

Changing Delays 
When you were trying to select About from the Options menu, you 
probably noticed that the sub-menu disapp-::ared if you moved the mouse 
off the Options menu item before a sub-menu item was highlighted. You 
may have also noticed that on your way to choose the Options menu 
some of the other hierarChic sub-menus appeared. 

There are two settings that can be adjusted for hierarchic menus: An 
"initial delay" and a "drag delay." The initial delay determines how soon a 
sub-menu will appear, and the drag delay determines how long the sub
menu will stay open. 

To change these settings: 
<D If the "About" dialog box is still displayed, click the mouse until 

just the "Open" dialog box is displayed. 

@) Hold down the (j and Control keys. While still holding down 
those two keys, press the Escape key. The graphic screen 
disappears and the Classic Desk Accessory menu appears. 

@ Press the Down Arrow to highlight the "Hierarchic Settings" 
option, then press Return. This opens the "Hierarchic Settings" 
classic (text-based) desk accessory. 

Each delay is set to O/60ths (no delay), but it is easier to choose sub-menu 
items if there is a delay. Delays are spedfied in "60ths of a second." For 
example, 1/2 second is 30/60ths of a second; 1 second is 60/60ths; 2-1/2 
seconds is 150/60ths and so on. The longest delay that can be set is 
254/60ths (slightly over 4 seconds). 

To increase each delay: 
® The Drag Delay option is already highlighted. Hold down the Left 

Arrow until the number is 240/60ths (four seconds). 
@ Press the Down Arrow to highlight the Initial Delay option. 
(§) Hold down the Rigbt Arrow until the number is 60/60ths (one 

second). 

(f) Press Escape to highlight the Quit option and press Return to go 
back to the Classic Desk Accessory menu. Press Escape to 
highlight the Quit option and press Return to go back to the 
graphic screen. 

Guided Tour: Viewing Kangaroo's Options 9 



To see the affect that the delay has: 
@ Open the Kangaroo menu and down to highlight the Options 

menu. Note that the Volumes menu does not pop open when 
you drag over it, and note that the Options sub-menu appears 
only after the main item is highlighted for one second. 

@ With the Options menu highlighted, drag down and to the right, 
making a beeline for the Preferences menu item. Even though 
you drag off the Options menu item the sub-menu does not 
disappear immediately. 

As you become more familiar with Kangaroo and using hierarchical 
menus, you will probably want to reduce the delays significantly (we use 
a drag delay of 120/60ths and an initial delay of 15/60ths). NOTE: Even 
with a long drag delay, fast vertical mouse motion will cause the sub
menu to disappear before the specified delay. Ibis is intentional to avoid a 
long delay if you accidentally highlight the wrong menu. 

PlayTime 
Practice choosing About from the Options menu until you get the feel for 
using hierarchical menus ... soon you will be addicted! 

Also, try choosing Help from the Options menu. Choosing a topic from 
the popup menu displays help information for that item. Click the close 
box to close the help window. NOTE: If you had to use the "Mini 
Kangaroo Installation" script then online help will not be available: 
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Preferences 
There are many ways to change Kangaroo's behavior, one of them is by 
settings Preferences. The Preferences dialog box contains many options, 
but right now we'll discuss just two of them: 

<D Choose Preferences from the Options menu. 

· Preferences 
: 181 Colored lists in StandardFile boxes 
! 0 Find file shortcut I Set it I 
! 0 OS utilities shortcut I Set it I 
: 0 "Save now" Kangaroo pre's shortcut 
: I Set it I 
j £8:1 Savewhen I quitting an application ~ 
! 0 Skip boot install I Set it I 

£8:1 Check 5.25" and 3.5" files/folders 
o Install sub-menu on "Open" itels 
£8:1 Draw icon at boot 
o Save positions in folders 

I Cancel II ... -OK-....... 

The Preferences dialog box 

Colored lists in StandardFtle3 boxes: This option determines whether you 
want the file list displayed in color (as it is now), or the way it is normally 
displayed. 

® If you prefer the normal file list display (no color), then uncheck 
the "Colored lists in StandardFile boxes" option. 

Check 5.25" and 3.5"files/folders: Whenever you pull down the Kangaroo 
menu, the status of the files and folders is checked. Right now you 
probably don't notice a long delay, but later in this tour you may find the 
delay with these slower disk drives annoying. 

@ If the delay when pulling down the Kangaroo menu becomes 
annoying, uncheck the "Check 5.25" and 3.5" files/folders" option 
to skip checking these slower disk drives. 

Now accept the changes: 

® Either click OK or press Return. 

3 "StandardFile" is the generic name for all the variations of the "Open" 
and "Save" dialog boxes. 
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Folders and Files 
Each time you open or save a file, Kangaroo automatically remembers the 
folder and filename, and adds them to the Folders and Files menus. 
Currently both of these menu items are dim because you haven't opened 
anything with Kangaroo yet. Let's add an entry to each of these menus. 

G) Find a document for the application you are using (e.g. if you are 
using GraphicWriter III, find a GraphicWriter III document). 
Preferably you should find a folder that contains many of these 
documents. 

® Open one document in the list (for the best effect, select one that 
is near the bottom of the list). 

® After the document is opened, close the document. 
@) Choose Open from the File menu. 
@ Pull down the Kangaroo menu and examine the Folders and Files 

menu items. You'll see that the document name was added to the 
Files menu and the name of the folder that contains the 
document ~as added to the Folder menu. 

Manually Adding A Folder 
Let's manually add a folder to the Folders menu so that we can 
demonstrate one reason Kangaroo is so useful. 

G) From the Volumes menu, choose the name of the disk you started 
the computer with. After doing so, the contents of your startup 
disk will be displayed in the file list. 

® Open the "System" folder. 
® Open the System. Setup folder. NOTE: It is not likely that any files 

will be displayed in this folder; don't worry . .. we're just using this 
folder as an example. 

@) Choose Add Current Folder from the Options menu. 

Now you should have two folders on the Folders menu ... "System. Setup" 
and the folder that contains the document you opened. 
NOTE: System.Setup is listed first because it is the most-recent addition. 
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Hopping Around 

The current list shows the contents of the System. Setup folder. Watch 
how easy it is for Kangaroo to hop to another location: 

G) On the Folders menu, choose the name of the folder that contains 
the document you opened. Hop! The file list shows the 
documents in that folder. 

® Choose System. Setup from the Folders menu. Hop! You're back 
in the System. Setup folder! NOTE: The order of the Folder menu 
items change as you use them; the most-recently used item always 
moves to the top. 

You can also choose the file you opened, and Kangaroo will hop back to 
where that file is stored. 

® On the Files menu, choose the name of the document you 
opened. Hop! Not only do you return to the list, but the file you 
chose is already highlighted!. 

But don't close this dialog yet. . .let's demonstrate one more cool feature! 

Direct Opening 
First we need set a preference to make Kangaroo do what we want: 

G) Choose Preferences from the Options menu. 
® Check the option to "Install Sub-Menu On 'Open' Items." 
® Click OK or press Return to accept the change. 

Now we're ready ... 

@) Open one of the documents in the list. 
@ Pull down the File menu to close the document, and you'll notice 

something new. Directly below the menu item you used to open 
the document will be another menu item with the same name. 
The second item is displayed in red, and the right arrow indicates 
it is hierarchical. 

@ Close the document. 

(j) Drag down to the new menu item and choose the document 
name from the sub-menu. The file is opened instantly, without 
ever asking you to find it! 
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Where To Go From Here 
This Guided Tour was just a brief introduction to Kangaroo. There are 
many more things it can do, and you should read the Reference section to 
learn all about them. 

The Reference section tells you how to: 

• Make folders and mes "permanent," and how to remove folders and 
mes that are no longer used. 

• Make the "direct open" menu item appear the next time you use an 
application, and why it shows all mes instead of just those that apply 
to the application. 

• Set up application "groups" with custom options for each group. 

• Find mes by a wide range of criteria. 

• Create new folders 

• Delete folders and mes 

.• Rename and change information about folders and files 

• Eject disks with the click of a mouse button 

• Erase and Format disks 

A Teaser 
If you're still in the application you were using during the Guided Tour, 
try this: 

<D If a document is open, close it 
® Choose Open from the File menu to get access to Kangaroo. 
@ Choose Group Setup from the Options menu. 
® Check the Show File Info option. 
@ Click OK or press Return to accept the changes. 
® Highlight a me or folder. 

If there's room at the bottom of the "Open" dialog box, you'll see two 
new lines that list the highlighted item's me type, auxtype, size, and 
created/modified dates. 

To learn all about the other cool things Kangaroo does, read the Reference 
section! 
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Reference 

The Reference section describes all the features found in Kangaroo. This 
section is organized by menu item-use it to learn about a specific feature. 

A particular topic or command also can be found in the Table of Contents 
or Index. 
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Folders 
The Folders menu displays the most recently-used folders for the 
application group you are using (see Group Setup for more information). 
TIP: To display up to 15 recently-used folders witbout regard for tbe Group, 
bold down tbe Option key before pulling down tbe Kangaroo menu. 

Each item on the Folders menu represef'ts a unique folder. The icon 
represents the type of volume on which the folder is stored. In 
parentheses is the name of the volume, and a colon for each folder 
between the volume name and the final folder name (if there are no 
colons then the folder is at the root level of the disk). 

Locked vs. Unlocked 
An unlocked folder (shown in blue) is temporary. As you use other 
folders, those new folders will be remembered. Eventually a 
temporary/unlocked folder might be replaced by a more recently-used 
folder. 

A locked folder (shown in black) is "permanent." It stays on the list until 
you remove it. This is useful for folders that you don't access frequently, 
but you still want quick access to (e.g. a "backup" folder you only use 
once a week). 

To change the locked/unlock status of a folder, hold down cJ before 
releasing the mouse button on the folder you want to change. When cJ is 
down, Kangaroo does not hop to that location. Instead, it locks or 
unlocks that menu item . 

Removing A Folder 
To remove a folder from the list, hold down Control before releasing the 
mouse button on the folder you want to remove. When Control is held 
down Kangaroo does not hop to that location. Instead, it removes the 
folder from the menu. NOTE: This even removes tbe folder if it is locked. 

Other Indicators 
Italic: The folder is on a disk that is not currently online. If you select 
this item you will be asked to insert the appropriate disk (click Cancel if 
you change your mind). 

Dim: The folder does not exist any more, or is not where Kangaroo 
expects it. Kangaroo remembers the full pathname of the folder; if you 
rename or delete any folder that is part of that pathname, Kangaroo won't 
be able to find the folder. 

Folders 17 



Files 
The Files menu displays the most recently-used files for the application 
group you are using (see Group Setup for more information). TIP: To 
display up to 15 recently-used files without regard for the Group, hold 
down the option key before pulling down the Kangaroo menu. 

Each item on the Files menu represents a unique file. The icon represents 
the type of volume on which the file is stored. 

Locked vs. Unlocked 
An unlocked file (shown in blue) is temporary. As you use other files, 
those new files will be remembered. Eventually a temporary/unlocked file 
might be replaced by a more recently-used file. 

A locked file (shown in black) is "permanent." It stays on the list until 
you remove it. This is useful for files that you don't access frequently, but 
you still want quick access to. 

To change the locked/unlock status of a file, hold down cJ before 
releasing the mouse button on the file you want to change. When cJ is 
down, Kangaroo does not hop to that location. Instead, it locks or 
unlocks that menu item. 

Removing A File 
To remove a file from the list, hold down Control before releasing the 
mouse button on the file you want to remove. When Control is down, 
Kangaroo does not hop to that location. Instead, it removes the file from 
the menu. NOTE: This even removes the file ifit is locked. 

Other Indicators 
Italic: The file is on a disk that is not currently online. If you select this 
item you will be asked to insert the appropriate disk (click Cancel if you 
change your mind). 

Dim: The file cannot be opened by the application, or the file has been 
moved, renamed, or deleted. 
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Volumes 
The Volumes menu displays all online volumes. The icon represents the 
type of volume. After the volume name is the amount of free space on 
the volume and the total size of the volume. NOTE: Some devices, 
particularly 5.25" drives, do not display the volume name, and instead 
show the "device name" with no sizes. This is normal. 

Choosing a volume displays the root level of the volume. 
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Options 
The Options menu contains all the options to manipulate the Folders and 
Files lists, and to set Kangaroo's configuration options. Online help and 
the "About" information are also available. 

Add Current Folder / Add Selected Folder 
This menu item is available when you are viewing the contents of a 
volume or folder. The title of this menu item changes because it is 
"context sensitive": If a folder is highlighted it reads "Add Selected 
Folder," otherwise it reads "Add Current Folder" 

Add Current Folder adds the folder you are currently viewing onto the top 
of the Folders menu. Add Selected Folder adds the highlighted folder 
onto the top of the Folders menu. If the added folder is already on the 
Folders menu it is not added a second time; instead the existing folder 
name is brought to the top of the menu. 

If you hold down the 0 key while adding a new folder, the folder will be 
added and locked (see the Folders section for more information). 

Add File 
This menu item is available when a file is highlighted. Add File adds the 
file onto the top of the Files menu. If the added file is already on the Files 
menu it is not added a second time; instead the existing file name is 
brought to the top of the menu. 

If you hold down the 0 key while adding a new file, the file will be 
added and locked (see the Files section for more information). 
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Purge Folders 
This option is dim if the Folders menu is empty. Otherwise it is active, 
and you can "purge" (or "remove") the following items from the Folders 
menu: 

All: Purges all the folders. 

Locked: Purges just the locked folders. 

Unlocked: Purges just the unlocked folders. 

Removable media: Purges just the folders stored on removable media, 
such as 3.5" or 5.25" disks. 

Dimmed: Purges just the dimmed folders (see the Folders section for 
more information). 

Purge Files 
This option is dim if the Files menu is empty. Otherwise it is active, and 
you can "purge" (or "remove") the following items from the Files menu: 

All: Purges all the files. 

Locked: Purges just the locked files. 

Unlocked: Purges just the unlocked files. 

Removable media: Purges just the files stored on removable media, such 
as 3.5" or 5.25" disks. 

Dimmed: Purges just the dimmed files (see the Files section for more 
information). 
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Preferences 
The Preferences dialog box lets you change the way Kangaroo works for 
you, 

Preferences 
, 181 Colored lists in StandardFile boxes 
o Find file shortcut I Set it I 
o OS utilities shortcut I Set it I 
o "Save notf" Kangaroo prefs shortcut 

I Set it I 
; 181 Savnhen I quitting an application ~ 
i 0 Skip boot install I Set it I 
: 181 Check 5.25" and 3.5" files/folders 
i 0 Install sub-menu on "Open" itells 
i 181 Draw icon at boot 
o Save positions in folders 

I Cancel I '-1 -o-K ---'. 

Ibe Preferences dialog box 

Colored lists in StandardFile boxes: Indicates whether file lists will use 
a colored background or not. This setting does not affect other color 
aspects of Kangaroo (i,e, its menus will always be in color). 

Find iue shortcut: The "Set It" button lets you define a shortcut key 
combination that will present the Find File option from within a desktop 
application (instead of having to open a StandardFile dialog box, then 
choosing Find File from the OS Utilities menu), 

For example, you can use d-Option-Shift-F, and pressing this key 
combination from within an application will immediately present the Find 
File dialog box, NOTE: Find File is not available in 320 mode, 

Because you will be issuing the key combination while using the 
application, it is important to choose a combination that is not used by the 
application. Good choices usually include combinations of the four 
modifier keys Cd, Option, Shift, and Control) plus some other key, 
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OS utilities shortcut: The "Set It" button lets you define a shortcut key 
combination that will present a StandardFile dialog box from within a 
desktop application, This dialog box lists all files Cnot just those that 
belong to the application, and even lists invisible files) so you can rename 
files, delete files, find files, and more! See the OS Utilities section for 
details on all the options that are available. 

For example, you can use d-Option-Shift-U, and pressing this key 
combination from within an application will immediately present a 
StandardFile dialog box that gives you access to the OS Utilities menu 

Because you will be issuing the key combination while using the 
application, it is important to choose a combination that is not used by the 
application, Good choices usually include combinations of the four 
modifier keys Cd, Option, Shift, and Control) plus some other key, 

"Save now" Kangaroo prefs shortcut: The "Set It" button lets you 
define a shortcut key combination that will save the current Kangaroo 
preferences. 

Normally the Kangaroo preferences are saved automatically, but you might 
want to save them manually after making many changes. After setting a 
key combination, you can press that combination and the current 
Kangaroo settings will be saved immediately. NOTE: Ibis optton saves all 
Kangaroo settings (the current Folders and Files menu items, Preferences, 
etc.), 

For example, you can use eJ-Option-Shift-S, and pressing this key 
combination from within an application will immediately present a 
StandardFile dialog box that gives you access to the OS Utilities menu 

Because you will be issuing the key combination while using the 
application, it is important to choose a combination that is not used by the 
application, Good choices usually include combinations of the four 
modifier keys Cd, Option, Shift, and Control) plus some other key, 

Save when quitting an application / closing the dialog: This option 
determines whether you want settings saved automatically, and how often 
the saving occurs, 

If you are using a fast storage device you can choose to save when closing 
the dialog without a noticeable delay Cfor example, RAMFast users won't 
see any delay), However, if you are using slow storage devices you will 
probably want to save only when quitting an application, 

If you tum off the checkbox Kangaroo will never save its settings, In this 
case you should set a "Save now" Kangaroo prefs shortcut key so you can 
manually save the settings when you desire, 
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Skip boot install: The "Set It" button lets you define a key combination 
that will prevent Kangaroo from loading when the system is started. 

For example, you can specify that Kangaroo will not be loaded if the "K" 
key is held down during the startup process. From then on, when starting 
the system just hold down the "K" key if you don't want Kangaroo to load. 
NOTE: Using "K" is just an example; in reality it is better to include one or 
more "modifier" keys along with a regular key (e.g. O-option-Shijt-K). 

Check 5.25" and 3.5" itles/folders: Each time the Kangaroo menu is 
opened it checks each item in the Folders and Files menus to see if it is 
currently online. With 5.25" and 3.5" disk drives this process can cause a 
noticeable delay in opening the Kangaroo menu, so unchecking this 
option tells Kangaroo to skip that process. 

The trade-off of not checking this option is that the list of Folders and 
Files might not be accurate ... with the option checked, items that are not 
available will be in italic, and files that are no longer present will be dim. 

Install sub-menu on "Open" items: This option determines whether 
Kangaroo will add a hierarchic menu in an application's menu. Choosing 
an item from the hierarchic menu lets you directly open the file, 
completely skipping the Standard File dialog box. We recommend you 
check this option .. .it will become indispensable very quickly! 

When this item is checked, any menu item you choose that eventually 
opens a Standard "Get" File dialog box will be duplicated in the 
application's menu. Kangaroo's hierarchical menu appears in red below 
the original menu item. NOTE: The new menu item is not added until 
after you use the normal menu item. 

This hierarchical menu will contain all of the items in the Files menu 
(whether or not they can actually be opened by the current application) 
because at this point Kangaroo has no way to determine which files 
belong to the application. Choosing an item that doesn't belong to the 
application won't be harmful; a dialog box will appear that states "The file 
does not exist or cannot be selected." 

NOTE: If the application is in the Universal group, the hierarchic menu will 
not appear the next time you start the application (but will be added again 
the first time you use an "open" menu item). To have the hierarchic menus 
added automatically the next time you start the application, the application 
must belong to a group other than "Universal." 

To change the locked/unlock status of a file, hold down 0 before 
releasing the mouse button. To remove a file from the list, hold down 
Control before releasing the mouse button. The I file will be locked or 
removed instead of opened. 
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Draw icon at boot: This option determines if Kangaroo will display its 
icon at startup. 

Save positions in folders: This option instructs Kangaroo to remember 
which item was selected the last time you opened something from this 
folder. Positions are saved separately for each group. 

For example, imagine you are using an icon editor and open the 
"Kangaroo.Icons" file that is stored in :Hard.DiskIcons: folder. The next 
time you choose Open you will be looking at the :Hard.DiskIcons: folder, 
but 'normally the highlighted item will be the first item in the list. If the 
"Save positions in folders" option is checked, the Kangaroo.Icons file will 
be selected automatically. 

NOTE: Kangaroo accomplishes this bit of magic by leaving invisible 
Kangaroo droppings in each folder, similar to the way the Finder 
remembers window sizes and views. KangarooData files will be written 
into each folder you work in (provided there is enough disk space and the 
disk is not write-protected). 

Group Setup 
Groups are used to assign applications you use into logical groups. For 
example, you can name a group "Graphics" and include all the graphic 
applications you use (e.g. Platinum Paint, SuperConvert, etc.). If you 
open a file with one of the applications in this group, the file will be 
remembered as belonging to that group. 

By using groups you can keep the number of Folders and Files down to a 
reasonable size; instead of having a single "group" that remembers all the 
folders and files you use, you can maintain separate lists of folders and 
files for each group ... entirely automatically once you assign an application 
to a specific group. NOTE: If you want to work on a file in a different 
group than the one your current application is in, hold down the option 
key before pulling down the Kangaroo menu and the last 15 folders and 
files used will be displayed regardless of group. 
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Assigning An Application To A Group 
To assign an application to a particular group, start the application and 
choose Open from the File menu (or choose any other menu item that 
presents a StandardFile dialog box). 

At the bottom of the Kangaroo menu is the name of the application you 
are currently using. Above that item the menu shows the name of the 
currently selected group (currently "Universal"). 

To assign the application to a particular group, highlight the Universal 
menu item and a hierarchical menu appears. Choose the particular group 
name from that sub-menu and the application will be assigned to that 
group. 

Using Group Setup 
Choose Group Setup from the Options menu to set preferences for each 
group. NOTE: The Group Setup dialog box initially displays tbe current 
group, but you can adjust settings Jor otber groups by cboosing tbe otber 
group Jrom tbe popup menu at tbe top oj tbe dialog box. 

Group 1 I Groupl 

Teach 
lord P,,,,,,ina 

Alert on sov •• rror 
Up.n the selected file 
Show file info 
Adjust polettI! 
Purge flIes at startup 
Purge folders at startup 
Auto rellove unknown 
Folder/File verify 

• of tl!lporary files : rn:J 
• of tl!lPorary folders: lliJ 

Rl!llove 
Cancel 

OK 

The Group Setup dialog box 

I 

The popup menu at the top of the dialog box lists the names of each 
group. Initially the groups are named "Group 1" through "Group 10" but, 
you can rename any of these groups by typing a new name in the edit 
box below the popup menu. NOTE: Tbe "Universal" group cannot be 
renamed. 
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The list box displays all the applications that belong to the group selected 
on the popup menu. You can remove an application from the displayed 
group by highlighting the application name, then clicking the Remove 
button. 

The following options can be specified for each group: 

Alert on save error: Checking this option will present an error message 
if Kangaroo has trouble saving his preferences. 

Open the selected me: Normally choosing a file from the Files menu 
simply jumps to the location of the file and highlights the file in the list. 
Checking this option instructs Kangaroo to automatically open the file. 

Show me info: Checking this option lengthens the StandardFile dialog 
box to include information about the highlighted file. The information is 
displayed only if a single item is highlighted, and only if there is room to 
display the information. 

The file's type, auxtype, and size is displayed on one line, and the file's 
creation and modification dates are shown on a second line. 

Adjust palette: Checking this option ensures that the StandardFile dialog 
box will be displayed using the correct palette. This is very useful when 
working in programs that change the standard color palette (e.g. painting 
programs). When closing the StandardFile dialog box, the application's 
palette is restored. 

Purge illes at startup: Checking this option will remove this group's 
unlocked files from the Files menu each time you start the computer. 
Locked files will remain on the menu until you unlock them (or use the 
Purge Files/Locked command on the Options menu). 

Purge folders at startup: Checking this option will remove this group's 
unlocked folders from the Folders menu each time you start the computer. 
Locked folders will remain on the menu until you unlock them (or use the 
Purge Folders/Locked command on the Options menu) . 

Auto remove unknown: When opening a StandardFile dialog, this 
option removes files that are not recognized by the application. 

FolderlFile verify: When opening a StandardFile dialog, this option tells 
Kangaroo to check each folder and file to verify that it still exists. Because 
Kangaroo looks at the disk it may take a few seconds if many folders and 
files are stored. A folder/file is removed only if the disk it is stored on can 
be located; if the disk is not found then the folder/file is left alone. 
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# of temporary f"1les: This value determines the maximum number of 
temporary files that can be recorded for this group (up to 99). 
NOTE: "Locked" files are not considered temporary; the number of locked 
files is limited only by available memory. • 

# of temporary folders: This value determines the maximum number of 
temporary folders that can be recorded for this group (up to 99). 
NOTE: "Locked" folders are not considered temporary; tbe number of 
lockedjolders is limtted only by available memory. 

Help 
Choose Help from the Options menu to open the online Kangaroo help. 
NOTE: Jf you had to use the "Mini Kangaroo Installation" script then 
online help will not be available. 

Choosing a topic from the popup menu displays help information for 'that 
item. Click the close box to close the help window. 

About 
Choose About from the Options menu to display information about 
Kangaroo. NOTE: Tb,is option is not available ,in 320 mode. 

NOTE: Jf you had to use the "Mini Kangaroo Installation" script then a text 
version of this dialog box will appear. ' 

When you are ready to proceed, click the mouse button and a second 
dialog box with "credits" appears. Click the mouse button again and 
you'll see that Kangaroo is personalized for you! Click once more and the 
About dialog box disappears. 
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OS Utilities 
Not only does Kangaroo hop around to quickly access your common files, 
but it also can perform many useful things, such as finding files, creating 
new folders, deleting files, renaming files, and so on. These "utilities" are 
found on the "OS Utilities" menu ("OS" is short for "Operating System"). 

Find File 
Shortcut: OF 

Choose Find File from the OS Utilities menu to find files. NOTE: This 
option is not available in 320 mode. 

o NOIRe 1 contains W I o Size 1 is less than ~ 1000001 1 kilobytes ~ 
o Kind is $1 0000 10 AUK $1000000001 ( Load Filetll~es ) 

o Creation date 1 is ~ C!!ll Juh ~ IJllil 
o Modification date I is ~ lEI July ~1Jllil 
Lock: I Ignore ~ Resource fork:l Ignore ~ 
ISearchl [£:.::] 0 Filter Search on : I A 11 vo I ae5 ~ 

~ Q 
: 

~ 
~ 

:Jr:.;~ ...J L':;'" !., ... 11 Done 
.. ' ....... IIIHlII HI"IIIIII"" "" 

The Find File dialog box 

Kangaroo offers many choices for finding files. Initially no criteria is 
specified so you can enter just the options you want. 
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Search Criteria 
Each choice begins with a label (Name, Size, Kind, Creation date, 
Modification date, Lock, and Resource fork). Next to the label are various 
options that can be set for that choice. These options should be self
explanatory when you read the entire option (e.g. "Name contains test" 
means to "find all the files whose name contains the letters t-e-s-t"). 

Most choices have a checkbox which determines whether that particular 
search criteria will be used (the exceptions are Lock and Resource Fork; to 
ignore that criteria choose "Ignore" from the appropriate popup menu). 
NOTE: Filling in part of an option automatically checks the corresponding 
checkbox. 

Special Notes 

Name: Capitalization does not matter (Le. TEST, test, and tEsT are all the 
same). 

Kind: You can search for a certain file type, auxtype, or both. Clicking 
the Load Filetypes button creates a popup menu from which you can 
select a filetype and auxtype by the document description. NOTE: After 
the Load Ftletypes button disappears and the popup menu appears, hold 
down the mouse button and wait for the chOiCes to appear ... it can take 1-2 
seconds on a standard lIGS. 

Fllter: Clicking the "Filter" checkbox tells Kangaroo to ignore any criteria 
you may have set, and instead to use the application's file filter. For 
example, imagine you are using GraphicWriter III and you chose Open 
from the File menu. If you use the filter checkbox to find files, Kangaroo 
will find all the files that GraphicWriter III can open. Likewise, if you are 
using Platinum Paint a "filter" fmd file would fmd all the files that Platinum 
Paint could open. 

Search on: This popup menu lets you choose whether to search all the 
online volumes or just a particular volume. 

Beginning the Search 
Click the Search button, or press Return, to begin searching for files based 
on the criteria you specified. When a matching file is located it is 
displayed in the list at the lower-left of the dialog box. 

Clicking on a found file displays its location in the list at the lower-right of 
the dialog box. NOTE: You don't have to stop a search to see where afile 
is located ... you can click on afile while Kangaroo is still searching. 

To stop searching, click the Stop button or press Esc. 
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When Kangaroo is finished searching you have four options: 

• Enter different criteria and perfoffil another search. 

• Click the Open button to open the highlighted file (this option is dim 
if you directly opened the Find File dialog using a keyboard 
shortcut. .. see Preferences for more information). NOTE: If the 
application cannot open the file then you will be told that "The file does 
not exist of cannot be selected." In this case tt does existj it just cannot 
be selected. 

• Click the Set To button to set the StandardFile location to the folder 
that contains the highlighted file (this option is dim if you directly 
opened the Find File dialog using a keyboard shortcut. .. see 
Preferences for more information). NOTE: If the file isn't displayed in 
the list box then you will be told that "The file does not exist of cannot 
be selected." In this case it does eXistj it just cannot be selected. 

• Click the Done button, or press cJPeriod, to close the Find File dialog 
box. 

New Folder 
Shortcut: cJ N 

Choose New Folder from the OS Utilities menu to create a new folder. 

New folder 

( Cancel ) (Create/Set) ( Create) 

The New Folder dialog box 

After typing the name for the new folder click Create to create the folder. 
Clicking Create/Set will create the folder, then open it. 
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Delete 
Shortcut: OK (as in "Kill" ... OD is used by System 6) 

Choose Delete from the OS Utilities menu to delete the highlighted items 
(this option is dim if no folders/files are highlighted). 

.. Do IIOU reallll want to delete 
~ File/Folder: Chris? 

(cancel) 

The Delete dialog box 

Delete can delete entire folders as well as files. For each item to be 
deleted, you are asked to confirm that you really want to delete the item. 
Click OK to delete the item, or click Cancel if you change your mind. 

CAUTION: When using an application you should not delete any files in 
the System folder, the application's folder, or any files that are currently 
often in the application. 
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Rename/Access 
Shortcut: or 
Choose Rename/Access to change information about the highlighted 
file(s). 

Access: Old.Letters 

181 Can delete 181 Backup needed 
181 Can write to 181 Can read from 
181 Can rename 0 Invisible 

Old tllpe $ OOOF Hew tllpe $ mID 
Old aux $ 00000000 Hew aux $1 00000000 1 

( Load til etllpes ) 

Creation date IT] [lli 119921 
Modification date IT] ill] [!ill] 

( Cancel) (Write Changes) 

The Rename/Access dialog box 

Unless you're an advanced user you should not change anything except 
the file's name. CAUTION: When using an application you should not 
rename any files in the System folder, the application's folder, or any files 
that are currently open in the application. 

Advanced users can change a file's individual "access" bits, its type and 
auxtype, and its creation and modification dates. To aid in changing the 
type and auxtype, click the Load Filetypes button to create a popup menu 
from which you can select a filetype and auxtype by the document 
description. NOTE: After the Load Filetypes button disappears and the 
popup menu appears, hold down the mouse button and wait for the choices 
to appear ... it can take 1-2 seconds on a standard lIGS. 

NOTE: The Load Filetypes button is not available in 320 mode. 

After making any changes, click Write Changes to write the changes to 
disk; otherwise click Cancel. Because changing some characteristics of a 
file might be bad, "Write Changes" always verifies that you really want to 
save the changes. 
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Eject Disk 
Choosing Eject Disk from the as Utilities menu presents a second sub
menu that lists all the removable devices. NOTE: OWners of the RAMFast 
SCSI card may notice that hard drive partitions are listed; this is because 
RAMFast marks these partitions as removable. Nothing actually happens if 
you try to eject a RAMFast partition. 

A StandardFile shortcut: LIE ejects the volume you are currently viewing 
(if it is removable). 

Erase Volume 
Choose Erase Volume from the as Utilities to erase a volume. 

Select device to erase 

( Cancel ) ( Erase) 

The Erase Volume 

Mter specifying the device to erase, click the Erase button. A second 
dialog box lets you change the volume name if desired. 

When you click OK, the standard Apple "Erase" dialog box appears. 
NOTE: There is a bug in System 5.0.4 that prevents the whole "Erase" 
dialog box from showing in 320 mode. This is fIXed in System 6. 

Mter choosing the disk format and size, click Erase to erase the chosen 
volume. 
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Format Volume 
Choose Format Volume from the as Utilities to format a volume. 

Select device to forillat 
_ .IMMERDRIVER.R2D.A -fr 

.....rr:l:llfi I 

I!l9 .DEV2 

~ 

( Cancel » ( For.at ) 

The Format DISk dIalog box 

Mter specifying the device to format, click the Format button. A second 
dialog box lets you change the volume name if desired. 

When you click OK, the standard Apple "Format" dialog box appears. 
NOTE: There is a bug in System 5.0.4 that prevents the whole "Format" 
dialog boxfrom showing in 320 mode. This isfIXed in System 6. 

Mter choosing the disk format, size, and interleave, click Initialize to 
format the chosen volume. 
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Application Group 
Below the divider line in the Kangaroo menu are two items: The 
application's group and the name of the application. 

Group Name 
The application belongs to the group that is displayed. If you select a 
different group from the hierarchic menu, the application will be moved 
into the new group. 

See Group Setup for more information about groups. 

Application Name 
This is the name of the application (or desk accessory, or CDEV, etc.) that 
you are working with. Choosing this item does nothing; it is provided 
only for your information. 
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Common Questions and Answers 
Please contact Seven Hills' technical support if this 

section doesn't answer your question! 

I was saving a file and was looking at a file list on a 3.5 R 

disk. I selected my hard drive from the Volumes menu. 
The hard drive was displayed, but the sizes were for the 
3.5· disk. Why does this happen? 
This is a known bug in System 5.0.4 and System 6.0. To switch to a 
different volume, Kangaroo sets the appropriate prefix then makes an 
operating system call to display the new prefix. Unfortunately that call 
does not handle everything correctly when switching from one volume to 
another. Hopefully Apple will fix this in a future update to System 6. 

Until then, this problem should not interfere with your work. .. just ignore 
the size numbers if you have switched volumes by using the Volumes 
menu. The only time it will interfere is when you switch from a locked 
disk to an unlocked disk ... StandardFile will think it is still dealing with a 
locked disk so the Save button will be dim. 

In this case (or if you must see the correct numbers), click the Close 
button then click the Open button and tl' StandardFile dialog box will 
display everything correctly. 
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What is "KRemove"? 
If you used the Full Kangaroo Installation script to install Kangaroo, 
KRemove will be located at the main level of the disk you installed on. 

KRemove is a Kangaroo utility that lets you quickly delete Kangaroo.Data 
or Finder.Data files from an entire volume. After launching KRemove you 
will see a dialog box similar to the following: 

This application allows you to delete Kangaroo.Data 
or Finder.Data files of your online vol .. es. 

@Delete Kangaroo.Data files 
o Delete Finder.Data files 

SI! I ect vo IUle I :Hard ~ 
Files scanned: 000000 Files deleted: 000000 
PathnClle 

« Quit J ( Delete ) 

The KRemove dialog box 

First choose the kind of files you want to remove (either Kangaroo.Data or 
Finder·. Data). Kangaroo.Data files remember which file was last 
highlighted in a particular folder; Finder.Data files remember the folder's 
window position, icon positions, and view. 

Use the "Select Volume" popup menu to select the volume you want to 
delete files from. If you want to delete files from a disk that is not listed 
in this popup menu, insert the disk then choose Update from the Update 
Devices menu. The disk you inserted will appear on the menu if it is 
recognized by GS/OS, but it is not selected automatically. NOTE: To 
delete tbe data files from all tbe volumes currently online, select All 
Volumes from tbe popup menu. 

Finally, click the Delete button to begin the deletion process. Because the 
process cannot be interrupted you are asked to confirm your decision. 
Click Yes and the specified items will be deleted. 

During the deletion process you are shown how many files have been 
scanned, the current folder being scanned, and how many .Data files were 
deleted. 

When you are finished deleting all the files you want, click the Quit 
button. 
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Kf1ngf1roo~ 
Seven Hills Software's Kangaroo adds itself into any "Open" or 
"Save" dialog box so you can quickly hop from one folder to 
another. It automatically remembers the recently used files and 
folders to make accessing them a snap. You no longer have to 
dig through folders to reach a particular file! 

And to save even more time, Kangaroo can add a new "Open" 
menu right inside your favorite IIGs-specific application. To open 
a recently used file, just select it from the hierarchical "Open" 
menu and it's opened immediately ... completely bypassing the 
file selection dialog box! 

Kangaroo also provides several useful . disk utilities that are 
accessible from within the program you are using. You can 
perform quick file searches, create folders, delete files, rename 
files, change file/auxtypes, and format or erase disks-all from 
within an Open or Save dialog box! 

Hop to it - buy Kangaroo today! 

Kangaroo requires an Apple IIGS with 1MB memory and one 3.5" 
disk diive. It- works with System Software 5.0.4 or later, and 
suppoitsany disk device that GS/OS recognizes. 

,- ~ . ' 

Suggested retail is only $49.95 

Seven Hills 
Soft ware 

o 7 Tallahassee, Florida • 904-575-0566 




